Remote Assistance through different listening port

TK

Distinguished
Apr 12, 2004
85
0
18,630
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have several machines behind a router and I have Remote Desktop set up
with port forwarding. I have had to change the listening ports on all but
one of the machines since my router only allows port forwarding, not
translating.
Now I am trying to use Remote Assistance on one of them, but when I receive
the request, there is no way I can see to tell it to use the assigned
listening port like I can with RDC - i.e. with RDC we type ip
address:listeningPort
Is there any way to make this work with Remote Assistance?
Thanks in advance.
TK
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"TK" <sprdthword@hotmail.com> wrote in message
news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
>I have several machines behind a router and I have Remote Desktop set up
> with port forwarding. I have had to change the listening ports on all but
> one of the machines since my router only allows port forwarding, not
> translating.
> Now I am trying to use Remote Assistance on one of them, but when I
> receive
> the request, there is no way I can see to tell it to use the assigned
> listening port like I can with RDC - i.e. with RDC we type ip
> address:listeningPort
> Is there any way to make this work with Remote Assistance?

Not sure what problem exactly you are having.

With Remote Assistance, if you have PCs behind a NAT router, you must:
- have UPnP enabled in the router;
- have "UPnP Framework" checked as an Exception in Windows Firewall in the
PCs.

Then Remote Assistance should look after itself. It does not always use a
fixed port number like Remote Desktop. It sends the IP address and
listening port number in the RA request ticket.

--
Robin Walker
rdhw@cam.ac.uk
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Additionally you might look at modifying the RCTICKET field in the invitation file if your *NOT*
behind a UPnP capable firewall/NAT/router...See this KB article for the file format...

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q300692

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Robin Walker" <rdhw@cam.ac.uk> wrote in message news:ckdgeb$7bq$1@gemini.csx.cam.ac.uk...
> "TK" <sprdthword@hotmail.com> wrote in message news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
>>I have several machines behind a router and I have Remote Desktop set up
>> with port forwarding. I have had to change the listening ports on all but
>> one of the machines since my router only allows port forwarding, not
>> translating.
>> Now I am trying to use Remote Assistance on one of them, but when I receive
>> the request, there is no way I can see to tell it to use the assigned
>> listening port like I can with RDC - i.e. with RDC we type ip
>> address:listeningPort
>> Is there any way to make this work with Remote Assistance?
>
> Not sure what problem exactly you are having.
>
> With Remote Assistance, if you have PCs behind a NAT router, you must:
> - have UPnP enabled in the router;
> - have "UPnP Framework" checked as an Exception in Windows Firewall in the PCs.
>
> Then Remote Assistance should look after itself. It does not always use a fixed port number like
> Remote Desktop. It sends the IP address and listening port number in the RA request ticket.
>
> --
> Robin Walker
> rdhw@cam.ac.uk
>
 

TK

Distinguished
Apr 12, 2004
85
0
18,630
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Robin,
Thanks for the quick response.
The problem I am having is that it is not letting me connect. I have gone
back into the machine in question and reset the listening port to the
standard 3389. I have set the router to forward calls to that port to the
internal ip address of this machine - which is a fixed ip address.
Remote Desktop works fine - but then that lets me specify the public ip and
the internal listening port.
I am using a D-Link DI-704P router which has a "virtual server" function
which allows me to route calls to a particular "service port" to an internal
IP address. So anything which hits the router with that port - 3389 - is
going to be sent to that machine.
What exactly is the request sending because the response needs to know the
public ip address to make the connection, so if it is only sending me the
internal ip address of the machine, that would be a problem. Is there any
way for me to see what the request is sending as far as ip information?
Thanks in advance.
TK

"Robin Walker" <rdhw@cam.ac.uk> wrote in message
news:ckdgeb$7bq$1@gemini.csx.cam.ac.uk...
> "TK" <sprdthword@hotmail.com> wrote in message
> news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
> >I have several machines behind a router and I have Remote Desktop set up
> > with port forwarding. I have had to change the listening ports on all
but
> > one of the machines since my router only allows port forwarding, not
> > translating.
> > Now I am trying to use Remote Assistance on one of them, but when I
> > receive
> > the request, there is no way I can see to tell it to use the assigned
> > listening port like I can with RDC - i.e. with RDC we type ip
> > address:listeningPort
> > Is there any way to make this work with Remote Assistance?
>
> Not sure what problem exactly you are having.
>
> With Remote Assistance, if you have PCs behind a NAT router, you must:
> - have UPnP enabled in the router;
> - have "UPnP Framework" checked as an Exception in Windows Firewall in the
> PCs.
>
> Then Remote Assistance should look after itself. It does not always use a
> fixed port number like Remote Desktop. It sends the IP address and
> listening port number in the RA request ticket.
>
> --
> Robin Walker
> rdhw@cam.ac.uk
>
>
 

TK

Distinguished
Apr 12, 2004
85
0
18,630
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Al,
Thanks - I was just about to write that I found the problem, the fact that
the invitation was sending my internal information
(machineName.DomainName:listeningPort) when I saw your post.
The link explains what I already figured out, but it does not say if there
is a way to force the invitation to include the correct public address - the
one our ISP assigns us.
Do you know if there is a registry hack for this? It sent the Public IP
assigned by the initial provider of our ADSL service, in our case the phone
company, but it did not pick up the IP assigned by our ISP which is what is
needed for access. When I took out the machine name string and replaced it
with that IP it made the connection fine.
Thanks in advance.
TK

"Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
news:%23A3Mns3rEHA.1816@TK2MSFTNGP09.phx.gbl...
> Additionally you might look at modifying the RCTICKET field in the
invitation file if your *NOT*
> behind a UPnP capable firewall/NAT/router...See this KB article for the
file format...
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q300692
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no
rights...
>
> "Robin Walker" <rdhw@cam.ac.uk> wrote in message
news:ckdgeb$7bq$1@gemini.csx.cam.ac.uk...
> > "TK" <sprdthword@hotmail.com> wrote in message
news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
> >>I have several machines behind a router and I have Remote Desktop set up
> >> with port forwarding. I have had to change the listening ports on all
but
> >> one of the machines since my router only allows port forwarding, not
> >> translating.
> >> Now I am trying to use Remote Assistance on one of them, but when I
receive
> >> the request, there is no way I can see to tell it to use the assigned
> >> listening port like I can with RDC - i.e. with RDC we type ip
> >> address:listeningPort
> >> Is there any way to make this work with Remote Assistance?
> >
> > Not sure what problem exactly you are having.
> >
> > With Remote Assistance, if you have PCs behind a NAT router, you must:
> > - have UPnP enabled in the router;
> > - have "UPnP Framework" checked as an Exception in Windows Firewall in
the PCs.
> >
> > Then Remote Assistance should look after itself. It does not always use
a fixed port number like
> > Remote Desktop. It sends the IP address and listening port number in
the RA request ticket.
> >
> > --
> > Robin Walker
> > rdhw@cam.ac.uk
> >
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Registry hack? I really don't know... This KB article seems to address what your seeing however...

http://support.microsoft.com/default.aspx?scid=kb;en-us;310612

Other KB articles concerning Remote Assistance...(Watch the line wrap)...

http://support.microsoft.com/search/default.aspx?InCC_hdn=true&Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&withinResults=&QuerySource=gASr_Query&Product=winxp&Queryc=remote+assistance&Query=remote+assistance&KeywordType=PHRASE&maxResults=150&Titles=false&numDays=&InCC=on
--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"TK" <sprdthword@hotmail.com> wrote in message news:%23g4APz3rEHA.3748@TK2MSFTNGP09.phx.gbl...
> Al,
> Thanks - I was just about to write that I found the problem, the fact that
> the invitation was sending my internal information
> (machineName.DomainName:listeningPort) when I saw your post.
> The link explains what I already figured out, but it does not say if there
> is a way to force the invitation to include the correct public address - the
> one our ISP assigns us.
> Do you know if there is a registry hack for this? It sent the Public IP
> assigned by the initial provider of our ADSL service, in our case the phone
> company, but it did not pick up the IP assigned by our ISP which is what is
> needed for access. When I took out the machine name string and replaced it
> with that IP it made the connection fine.
> Thanks in advance.
> TK
>
> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
> news:%23A3Mns3rEHA.1816@TK2MSFTNGP09.phx.gbl...
>> Additionally you might look at modifying the RCTICKET field in the
> invitation file if your *NOT*
>> behind a UPnP capable firewall/NAT/router...See this KB article for the
> file format...
>>
>> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q300692
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>>
>> "Robin Walker" <rdhw@cam.ac.uk> wrote in message
> news:ckdgeb$7bq$1@gemini.csx.cam.ac.uk...
>> > "TK" <sprdthword@hotmail.com> wrote in message
> news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
>> >>I have several machines behind a router and I have Remote Desktop set up
>> >> with port forwarding. I have had to change the listening ports on all
> but
>> >> one of the machines since my router only allows port forwarding, not
>> >> translating.
>> >> Now I am trying to use Remote Assistance on one of them, but when I
> receive
>> >> the request, there is no way I can see to tell it to use the assigned
>> >> listening port like I can with RDC - i.e. with RDC we type ip
>> >> address:listeningPort
>> >> Is there any way to make this work with Remote Assistance?
>> >
>> > Not sure what problem exactly you are having.
>> >
>> > With Remote Assistance, if you have PCs behind a NAT router, you must:
>> > - have UPnP enabled in the router;
>> > - have "UPnP Framework" checked as an Exception in Windows Firewall in
> the PCs.
>> >
>> > Then Remote Assistance should look after itself. It does not always use
> a fixed port number like
>> > Remote Desktop. It sends the IP address and listening port number in
> the RA request ticket.
>> >
>> > --
>> > Robin Walker
>> > rdhw@cam.ac.uk
>> >
>>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

There's no hack to fix this.

Robin Walker has given the right information, though--one way to fix this is
to use a UPnP capable router, and have the relevant services turned on on
the target machine. That will allow Remote Assistance to put the right info
into the ticket.

You might check whether firmware revs for your router might enable this
functionality.

Otherwise, editing the ticket is one way to work around the issue.

"TK" <sprdthword@hotmail.com> wrote in message
news:%23g4APz3rEHA.3748@TK2MSFTNGP09.phx.gbl...
> Al,
> Thanks - I was just about to write that I found the problem, the fact that
> the invitation was sending my internal information
> (machineName.DomainName:listeningPort) when I saw your post.
> The link explains what I already figured out, but it does not say if there
> is a way to force the invitation to include the correct public address -
> the
> one our ISP assigns us.
> Do you know if there is a registry hack for this? It sent the Public IP
> assigned by the initial provider of our ADSL service, in our case the
> phone
> company, but it did not pick up the IP assigned by our ISP which is what
> is
> needed for access. When I took out the machine name string and replaced it
> with that IP it made the connection fine.
> Thanks in advance.
> TK
>
> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
> news:%23A3Mns3rEHA.1816@TK2MSFTNGP09.phx.gbl...
>> Additionally you might look at modifying the RCTICKET field in the
> invitation file if your *NOT*
>> behind a UPnP capable firewall/NAT/router...See this KB article for the
> file format...
>>
>> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q300692
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>>
>> "Robin Walker" <rdhw@cam.ac.uk> wrote in message
> news:ckdgeb$7bq$1@gemini.csx.cam.ac.uk...
>> > "TK" <sprdthword@hotmail.com> wrote in message
> news:OBuEKs2rEHA.3252@TK2MSFTNGP14.phx.gbl...
>> >>I have several machines behind a router and I have Remote Desktop set
>> >>up
>> >> with port forwarding. I have had to change the listening ports on all
> but
>> >> one of the machines since my router only allows port forwarding, not
>> >> translating.
>> >> Now I am trying to use Remote Assistance on one of them, but when I
> receive
>> >> the request, there is no way I can see to tell it to use the assigned
>> >> listening port like I can with RDC - i.e. with RDC we type ip
>> >> address:listeningPort
>> >> Is there any way to make this work with Remote Assistance?
>> >
>> > Not sure what problem exactly you are having.
>> >
>> > With Remote Assistance, if you have PCs behind a NAT router, you must:
>> > - have UPnP enabled in the router;
>> > - have "UPnP Framework" checked as an Exception in Windows Firewall in
> the PCs.
>> >
>> > Then Remote Assistance should look after itself. It does not always
>> > use
> a fixed port number like
>> > Remote Desktop. It sends the IP address and listening port number in
> the RA request ticket.
>> >
>> > --
>> > Robin Walker
>> > rdhw@cam.ac.uk
>> >
>>
>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"TK" <sprdthword@hotmail.com> wrote in message
news:%23g4APz3rEHA.3748@TK2MSFTNGP09.phx.gbl...
>
> I was just about to write that I found the problem, the fact that
> the invitation was sending my internal information
> (machineName.DomainName:listeningPort) when I saw your post.
> The link explains what I already figured out, but it does not say if there
> is a way to force the invitation to include the correct public address -
> the
> one our ISP assigns us.

This is why you need to get UPnP working between the router and the XP PC.
Remote Assistance uses UPnP to discover the external WAN IP address. so that
RA can write the external WAN address into the request ticket.

--
Robin Walker
rdhw@cam.ac.uk
 

Latest posts