Question Rust low FPS

Ashenn

Reputable
May 3, 2017
31
0
4,530
0
I have a 2080ti, TR 3970x, and 64GB 2666 RAM. I'm getting around 80fps in rust on 1080p and think the reason for my low fps is my cpu. Is there a way i can boost my FPS? On my old PC i got around 140-180 (1080ti, 8700k, 32GB 2666) Thanks!
 

Phaaze88

Glorious
Ambassador
Disable like, 56 threads. No, I'm not kidding.
The game isn't well optimized and doesn't know what to do with 64 threads available for use.

The idea came from another user who had problems with low performance on their Ryzen 3900X(12 core/24 thread). Disabling about half the threads fixed it for them. You've got way more than that though.
Very few games can actually work with 9+ threads.
 

Ashenn

Reputable
May 3, 2017
31
0
4,530
0
Disable like, 56 threads. No, I'm not kidding.
The game isn't well optimized and doesn't know what to do with 64 threads available for use.

The idea came from another user who had problems with low performance on their Ryzen 3900X(12 core/24 thread). Disabling about half the threads fixed it for them. You've got way more than that though.
Very few games can actually work with 9+ threads.
How do i do this? I've never had an issue like this and am having trouble finding an actual guide for this. Thanks alot by the way!
 

Phaaze88

Glorious
Ambassador
ASUS ROG Strix TRX 40-E Gaming
No dice; not an option to do that, so instead, please open Rust, then Task Manager and click on Details.
Find Rust on the list, right-click it and click on Set Affinity. You should then get a new window asking, "Which processors are allowed to run this app?"
Disable all, except for 8 of them, then click OK and exit. Try the game again.
 

Ashenn

Reputable
May 3, 2017
31
0
4,530
0
No dice; not an option to do that, so instead, please open Rust, then Task Manager and click on Details.
Find Rust on the list, right-click it and click on Set Affinity. You should then get a new window asking, "Which processors are allowed to run this app?"
Disable all, except for 8 of them, then click OK and exit. Try the game again.
Says access denied, tried running task manager as admin and didn't work.
 

Phaaze88

Glorious
Ambassador
Well, fiddlesticks. That's a new one for me!
Just Access Denied, no reason given? Perhaps that was too many... Does disabling half work?
I'm about stumped here - the reason for the current performance is the whopping 64 threads your cpu has, but I don't know how else to deal with it beyond bios and Task Manager...
 

Ashenn

Reputable
May 3, 2017
31
0
4,530
0
Well, fiddlesticks. That's a new one for me!
Just Access Denied, no reason given? Perhaps that was too many... Does disabling half work?
I'm about stumped here - the reason for the current performance is the whopping 64 threads your cpu has, but I don't know how else to deal with it beyond bios and Task Manager...
Yeah, and my account is an admin account so idk. Maybe do it through an elevated cmd? I really have no clue at this point.
 

Ashenn

Reputable
May 3, 2017
31
0
4,530
0
Apparently it's an issue with the game's anti cheat, which prevents you from being able to change priority or affinity. Any workarounds?
 

ASK THE COMMUNITY

TRENDING THREADS