Question RX 580 default clock @ 1085 Mhz?

plshelpmyproblems

Reputable
May 26, 2014
30
1
4,535
0
I bought a second hand HIS RX580 IceQ X2 8GB and apparently when I opened GPU-Z the default clock is only 1085 Mhz. The website on the card itself says the default clock should be 1257 Mhz and the set clock is nowhere near. I have tried playing video games and running furmark, monitoring if it will ever change but it did not. What is this supposed to be? I am in contact with the seller, and he seems very open about it.

This is the GPU-Z snapshot
 

plshelpmyproblems

Reputable
May 26, 2014
30
1
4,535
0
What are your full PC specs ? Which PSU are you using ? Is the card seated on the primary PCI-e x16 slot of your motherboard ? Have you also checked the PCI-e settings in BIOS ?
I have a 4th gen i7, 8 gigs of RAM, and a trusty 620 watt Seasonic PSU. Yes, my card is seated on the gray slot of the B85 Pro Gamer motherboard.
If you ask me, I would not blame my own PSU (i just trust it so much lol). The one I would blame is the motherboard, which I am sure has an issue of a bent pin, which affects the two other slots of RAM making them not work.
However, I fail to see how this can potentially affect the default clock of this GPU, unless the GPU itself is the it.
 

plshelpmyproblems

Reputable
May 26, 2014
30
1
4,535
0
I found out the reason myself. Turns out that it most probably came from a miner, and had modded it, thankfully, to a lower clock so it had less abuse (or so it says).
I searched around for the default BIOS that contains the default clock speed for this specific card and flashed it.
 
Reactions: TJ Hooker

ASK THE COMMUNITY

TRENDING THREADS