Question Steelseries Rival 600 mouse not working after connector unplugged

Aug 17, 2020
9
0
10
0
My rival 600 that I got for Christmas 2018 has suddenly stopped working, it is extremely hard to use the left mouse button and I can't hold it down for more than a split second. This issue started when the micro usb cable that plugs into the mouse got nudged, I unplugged it and plugged it back in multiple times, and it still is misbehaving, my right click still works however. All of my drivers are up to date, I have the most recent version of windows, and my mouse software is up to date as well and doesn't show any problems there.
 

hang-the-9

Titan
Moderator
Sounds like you have hardware issues nothing with software. Test it on another system to verify, if it does the same thing you can either try taking it apart and cleaning out the switch and checking the USB connector that may need to be soldered again or replace the mouse.
 
Aug 17, 2020
9
0
10
0
Sounds like you have hardware issues nothing with software. Test it on another system to verify, if it does the same thing you can either try taking it apart and cleaning out the switch and checking the USB connector that may need to be soldered again or replace the mouse.
How would i take it apart? i dont see any screws
 
Sep 24, 2020
5
0
10
0
The screws on the Rival 600 might also be in-between the side grips if they aren't on the feet.

(When you take the side grips off, they are magnetic i think the screws are there)
 

ASK THE COMMUNITY

TRENDING THREADS