Strange Mobo issue / Hard-disk Issue


Sep 11, 2007
I have an ongoing issue with my computer. I consider myself an expert, yet it leaves me kind of stumped. None of the people I know in IT had heard of this happening so I bring it here to perhaps gain some insight.


Windows installer cannot find any Hard Disks – (When in RAID mode Bios settings)


This computer ran great for 2 years. (2 Drives in RAID 0 and 1 Drive as a Storage JBOD) Friday after work it boots up saying the Windows System32/system folder was missing.

WHAT I DID originally:

F8 - attempted to boot last known good config. (Still missing file, would not boot) F8 - attempted to boot safemode. (Still missing file, would not boot) Windows system Recovery. Microsoft guide as to how to copy/load your old existing backups to the system32 folders. (The recovery console Claimed Access Denied and could not find the C drive. When I tried to scan the hard disk, there were 1 or more errors reported Immediately - I didn't even get a 0% scanned) - I thought a hard drive die on me.

HARDWARE: (original)

ABIT AN8 Ultra Motherboard
2x WD Raptor 34g HDs (Running Tandem Raid 0 setting)
1x WD 250g Cav. (JBOD)
AMD x2 4200
2x 1G Corsair 400 DDR


Thinking I had a hard drive failure, I first went into BIOS to be sure the raid settings did not get messed up accidentally (All were still on/good). I then went into (F10) my Raid controller (Which saw all of the harddrives and reported no problems with them) and cleared the Raid 0 partition (Which was just running Windows). I left the JBOD alone and disconnected it completely. After low level formatting and separating the partition I rebooted trying to load windows from either WD Raptor Drive to determine which had gone bad... The windows XP cd could find no hard disks installed to install windows to... I went so far as to connect them separately (SATA drives) in each of the 4 different sata sockets. No Dice.


Either all 3 hard drives failed at the same time... (Highly Unlikely) or the Sata connectors on my Mobo all (4) died... or the Raid controller lost communication with any other area of my Mobo...

The Raid Controller saw all 3 hard drives Flawlessly - which leads me to believe that the hard drives are fine and some circuit on the Motherboard died.


I had loaded the Raid drivers (that came with the AN8 Ultra board like I did originally when I created the system) every time. No Dice, windows installer still didn't see the Raid created drives.

IDE Mode in Bios sees all 3 drives fine - I can see (in Boot Priorty BIOS menu) the raid Drives when I convert them to RAID mode (and create an array) but windows installer still does not see them.

When the Hard Drives are in a RAID Array configuration they can only be seen in Bios on the Boot Priority Menu.

I decided to upgrade my Mobo and sold my Microchip and Ram to upgrade those as well thinking that might solve the problem...

It did not solve the problem –
Upgraded to:

KN52 board
AMD x2 4800 chip
2g dual channel Ballistix RAM.

Still when Bios is in IDE mode when I load the controllers windows sees all 3 Hard drives perfectly - yet when I set BIOS to RAID Mode (Raid sees all 3 drives perfectly) yet windows installer does not.

I split Both Raptor Drives apart and I installed windows under IDE mode on it. My other (WD250 Cav) Drive is seen in Computer management but is unrecognizable, so I cannot pull data off of it. It was a JBOD (solo storage disk). (Both Raptors basically just ran windows in Raid 0 which was why I was quick to clear them)


At this point I am going to update the Board Bios to latest version and see if it recognizes the RAID drivers in windows installer...

My XP Pro disc is really old (Close to when Windows XP originally came out) and I am beginning to suspect that it might be the problem…

BUT – Originally when I initially built the system on the AN8 board it worked perfectly.


If anyone can help me re-establish a RAID on this system I’d be appreciative.


If re-establishing a RAID seems to be unlikely can anyone help me with data recovery on a JBOD disk that sat there as storage for my initial RAID?

The data on the disk should be intact; I just need to access it. With IDE mode bio setting - windows installed on a Raptor finds the JBOD drive (WD250 Cav) but says it is unrecognizable so I can not label the drive and view its data. When I set Bios to RAID mode, the Raid controller sees the JBOD perfectly, yet I can not get into any version of windows.



Sep 11, 2007
Update bump:

Ran Western Digital Diagnostic tools - all 3 Hard drives check out healthy.

Can anyone help me with some insight?


Dec 17, 2003
I had 2 Raptors (not in RAID) fail at different times in similar circumstances on a Via K8T800 chipset mobo - it just stopped recognising them.
Other HDDs worked fine.
I stopped using Raptors.


Dec 7, 2007
Almost the same problem if I am reading right. Take out Raid and you can see the SataII drives and the Sata DVD in the main Bios. Implement a Raid 1 Array and nothing is recognized in the main Bios but everything works perfectly. From what I have been reading there is the possibility that the drives, when Raided, come under the control of whatever Raid Bios your machine uses. I have reloaded the Raid1 Array and Windows 4 different ways in the last 2 days and the results are the same. Shows up in the device manager, the bootsequence part of the bios and everywhere else BUT the main Bios. Is this normal? Is this a Bios glitch that should be addressed by the manufacturer?....or is it something else.....