Question Stuck at windows logo after BIOS update

May 28, 2020
5
2
15
0
Hello everyone,

There is an issue that I've been struggling with for some time.

My MOBO is a Gigabyte x570 Gaming X, and it only boots Windows with the BIOS version F4g. Anything lower or higher, the PC just stays at windows loading screen and the loading indicator spins forever. If i try to run the 'Start up recovery', it loads for a minute and then sits at a black screen.

Without anything else to try, I recover my BIOS (F4g) from a backup and it starts to work again.

My drives are recognised after the update and the boot order is correct. I also tried removing the CMOS battery.

What do you think that I should do? I definitely don't want to start from scratch by formatting my OS drive. I just want to be sure that i'm not missing anything. Overally I'm happy with the version that I have but people say the last versions have lower idle temps and better performance for the CPU which is a R5 3600.
 

kurdtnz

Great
Feb 24, 2020
201
17
95
1
I have the Gigabyte x570 i aorus pro wifi board, when I first got it the BIOS was F3, I flashed to F11 and have had no issues. Get some advise from someone more experienced before you do anything though as messing around flashing the BIOS can screw your board if done incorrectly.
 
May 28, 2020
5
2
15
0
Bios update is the most scariest thing for me. The thought of bricking the motherboard hunts me in my dreams (lol). That's why I don't try updating it anymore. I just came here so maybe someone could give me an idea worth trying.

Worst case scenario, I'll update it if I decide to reinstall windows for some reason.
 
Reactions: kurdtnz

ASK THE COMMUNITY

TRENDING THREADS