• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Stuck with timed frame spikes and stutter... run out of fix ideas...

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
Ok, so here we go... here are my specs:

Processor: I9 9900k
GFX: Asus RTX 2080ti
Motherboard: Asus z390-F
RAM: 4x8 Corsair 3200mhz
PSU: EVGA 750 G2 (eco mode on)
OS: Win10 64 bit

GFX & CPU temps idle: 38-40 Celsius
Cooler: NZXT Kraken x73
2 X M.2 drives, one only for windows and related software, other is games.

Using afterburner, Frame limited by RTSS. Mild overclock on GPU, issue exists even if disabled. No CPU overclock.

--

My issue is that I get very specific timed frame spikes (either up or down) which can be seen in RTSS stats and visually on screen. This removes smoothness and in game jutters about every second, which is my issue.

Even with my hardware I can set a game to 60fps lock, and same in RTSS, lowest settings, and the issue remains, even though my hardware can handle way more.

I have tried so much of everything. No thermal throttling that I can tell. At GPU max 100% temp is max 60-70deg. CPU never goes over 50% usage.

I have attached some relevant screens to show this issue. (images are also here View: https://imgur.com/a/vIBRPQ4
) If I can supply anything more, please let me know.

View: https://imgur.com/h916vtT
(Frame spikes down)
View: https://imgur.com/m0zz9rE
(Timed frame spikes both directions)
View: https://imgur.com/DVfCVNC
(Nvidia settings 1)
View: https://imgur.com/sAJ77Iy
(Nvidia settings 2)
View: https://imgur.com/uDPSyQZ
(MSI afterburner stats)
 
What all have you tried? It's better you mention it all rather than us repeating everything you might have already done. My first instinct would be to suggest removing current drivers using display driver uninstaller and then install latest version, and also a BIOS update.
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
What all have you tried? It's better you mention it all rather than us repeating everything you might have already done. My first instinct would be to suggest removing current drivers using display driver uninstaller and then install latest version, and also a BIOS update.
I have tried so much it is hard to remember. So to simplify things, I did a clean install of Nvidia drivers, after using display driver cleaner in safe mode. I checked my BIOS, and it is at the latest version.

I loaded up Kombustor and you can see (image below) the issue is still present :( I am willing to try anything at the moment.

View: https://imgur.com/pb1K5Ev
 
Have you tried putting Vsync on fast or even ultra?
Also try hardware scheduling which is a new feature.

What this looks like is a problem with synchronization between the GPU and the monitor,what kind of monitor is it?!Do you have any other display just to try out,even a TV or anything.
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
Have you tried putting Vsync on fast or even ultra?
Also try hardware scheduling which is a new feature.

What this looks like is a problem with synchronization between the GPU and the monitor,what kind of monitor is it?!Do you have any other display just to try out,even a TV or anything.
The monitor is a Samsung CRG9 32:9 120hz - I tried my old 144hz monitor and it was the same issue.

Yes I tried the Vsync, all options, on and off. Same issue persists. As to the hardware scheduling, I did not have that option, so I updated windows by force and now have the setting.

It made things... different. I think it is a bit better. I have to use vsync in game or if I use nvidia vsync I get the constant dips again. I need to test more to be sure though.

I am starting to feel more and more this is the timing between windows and the application.
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
Try disabling the motherboard HPET timer...Windows will use it's own if HPET is disabled.

Have you tried it with Afterburner and RTSS uninstalled ?
Seems my mobo does not have a switch for that (Asus Z390-F gaming). I think you could be on to something. I ran WinTimerTester and it shows 10Mhz fixed Query performance frequency.

The software commands when googling HPET seem to have no effect though:
bcdedit /set disabledynamictick yes
bcdedit /set useplatformclock true

hardware scheduling seems to have helped a lot but I feel like we just avoided the problem by going hardware... if that makes sense... :)
 
The monitor is a Samsung CRG9 32:9 120hz - I tried my old 144hz monitor and it was the same issue.
Why are you limiting your FPS to 60 on 120 and 144 monitors? If you want to do this you should also "downclock" your display to 60Mhz so that it will sync up better.
The software commands when googling HPET seem to have no effect though:
The timer can have a big effect on some games but it only affect a very few games,you have a problem in everything you run so I don't think that the timer has anything to do with your issue.
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
Why are you limiting your FPS to 60 on 120 and 144 monitors? If you want to do this you should also "downclock" your display to 60Mhz so that it will sync up better.

The timer can have a big effect on some games but it only affect a very few games,you have a problem in everything you run so I don't think that the timer has anything to do with your issue.
Hello :) I only limited it to 60 to test if the issue existed at lower frame rates as well and was not just an issue reaching max FPS.

The sweet spot for my monitor is 100Hz - as the monitor only supports 10bit color full range at this, with HDR1000. If I set the monitor to 120Hz I have to use 8bit color.

So I use RTSS to limit the monitor to 97fps with the monitor set to 100Hz
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
Thanks to much to everyone so far for help with this @Shektron @dorsai @TerryLaze (y)🆒

It seems when I enable WIndows Hardware Accelerated GPU Scheduling the problem is gone but replaced with another "oddness" = a stable FPS but as soon as a busy scene (like an explosion) the fps dips for like a split second (like a vertical line in FPS graph) to a very low fps and freezes for that split second.

I think this above may indicate where the issue likes with not hardware scheduling, if that makes sense?

Maybe thats just the way it should work and the GFX settings are too high? I can post a little video of this effect if you like?
 

alskadotme

Reputable
Mar 28, 2017
9
0
4,510
0
As a last comment here for anyone who reads this post thread, hardware scheduling made the world of difference. Benchmarking in Assassins Creed Odyssey for example shows ZERO stutter.

DX12 & Vulkan still has some issues, but I think this is because of the implementation and being relatively new.

Thanks again to all for the help :)
 

ASK THE COMMUNITY

TRENDING THREADS