Question TP Link wireless adapter giving slow transmit rate

Shubham Deshpande

Honorable
Sep 8, 2014
7
0
10,510
0
My Archer T9E has been working flawlessly since 2017. Giving a transmit rate of 1300 MHz on 5GHz band. It even allowed me to cast full size 4K HDR movies on my Chromecast Ultra. But as of late the adapter has started giving some problems. The transmit rate is between 1 - 130 MHz which generally settles at 13MHz. Only at the time of startup does it go above 130 MHz sometimes even reaches the full 1300 for a few seconds. After this problem started I've not only tried everything with network troubleshooter and router settings, which by the way is working fine sine there are no issues with my phone or laptop, I've also reinstalled my driver and utility. Since then I've even clean installed my windows due to some separate issues (After which it worked fine for few minutes). I've also made sure that my card is seated properly and that there are no obstacles. Does anyone have any idea how to fix this as I'm getting really desperate? Thanks in advance.
 

Lutfij

Titan
Moderator
Stating you clean installed the OS, which version of the Windows 10 are you? You didn't mention much about the OS, which is why I'm assuming you're on Windows 10. Which version of the motherboard BIOS are you currently on?

Make and model of your wireless router and it's firmware version?
 

Shubham Deshpande

Honorable
Sep 8, 2014
7
0
10,510
0
Hi Lutfij,

Thanks for trying to help.
And sorry for the lack of details.
I'm listing below all the details you asked for.
But since you mentioned Windows version and clean install, let me clear the fact that I did a clean install after this problem and the problem persisted atleast on the upload side, not as much on download but the transmit rate show by Tp Link is still low as before.
And also the fact the problem started after I installed the update for 1903, since they were stopping support for 1803.

OS: Win 10
Version: 1903
Mobo: P8P67 Pro
Bios: 3602
Router: Netgear R6700 V2
Firmware: V1.2.0.62_1.0.1
 

ASK THE COMMUNITY

TRENDING THREADS