• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Tried multiple methods, 100% cannot enter the bios

Jun 26, 2020
2
0
10
0
I've checked every bit of information, tried every method that I've seen ranging from doing doing commands in CMD to toying with the windows recovery options.

I'm on windows 10 pro 2004
ryzen 3700x
gtx 1080
32 gb of corsair ram
asus prime x570 pro
corsair 1000 watt platinum power supply

windows is on a samsung 250gb 970 evo I think

I've had this build running with no issues for a while now, but I had to do a clean install of windows and it seems to have messed EVERYTHING up (not realizing that we got the 2004 update didn't help)

I have all of the proper drivers installed, I've checked all of the connections on my motherboard, nothing extra is plugged in.

sorry if I seem demanding, it's not what I intend with this, but this is kind of my last ditch effort without getting any new parts.
 
Last edited:

ASK THE COMMUNITY