Question Updates: 3080 Poor Performance in My PC

ludinkog

Reputable
Jun 1, 2016
29
1
4,535
0
I made a post some time ago in regards to my new 3080 really underperforming in most games. This an update with results I have found.

Specs:
Strix 3080
i9 9900KF
MSI MPG Gaming Edge AC
2x8gb ram cl15 3000mhz
2tb 970 Evo SSD
NEW Seasonic Prime 850 Gold PSU

So, I put the 3080 in my pc, run DDU, and try some games. My frames are really not what they should be.. 160-200 in Siege now, 1440p ultra, though it used to be more like 130-150. My friend, who has nearly identical specs, was getting 300-400 fps. Had 1000w gold psu, thought it might be power issue. No change. Thought it might be ram issue, threw in my brothers 4x8gb 3200mhz ram, no change. Now I will link some pics of my pc/gpu benchmark performance.

My PC, first test before any changes, TimeSpy

My PC, first test before any changes, Fire Strike

My PC, new windows update, TimeSpy

My PC, new windows update, Fire Strike

My friends PC, my GPU, TimeSpy

My friends PC, my GPU, Fire Strike

Where I have a 9900KF, he has 10700K, so nearly same specs. While benchmark performance isn't important to me, the in game performance hit is really annoying. What do y'all think my issue is? I guess the only parts left to cross check are CPU and Mobo. Can either of those 2 have a significant enough difference in performance?
 

ludinkog

Reputable
Jun 1, 2016
29
1
4,535
0
Update, replaced the motherboard and issue remains. Now technically just the CPU remains, but as the cpu is relatively new, I'm not sure it should have any issues. I did notice that in games, my cpu usage is quite low. In Warzone, hovers between 30-45%, in siege around 35-40%.
 
Are the in game graphics settings the same and the monitor settings the same?

Try running the gears of war 4 benchmark or shadow of tomb raider benchmark and report back if the cpu frame times or gpu frame times are different between the two systems.

The kf chip disables some iGPU functionality. If the code calls that functionality and it's not there it will have to go to the fallback layer.
 

ASK THE COMMUNITY

TRENDING THREADS