Question US language input keeps being re-added after every restart

Tornik

Commendable
Feb 16, 2017
71
2
1,545
2
So I use two inputs for my keyboard: UK English with US international layout and Georgian QWERTY. Despite deleting the US input that comes installed with Windows 10, it gets re-added to these two after every restart. It is not listed in languages when I click language bar and go to 'Language preferences', but is visible in the language bar list itself.

I found a number of suggestions online for solving this (e.g. deleting the HKEY_USERS/.DEFAULT/Keyboard Layout/Preload folder), but they only work until a restart.
 

Tornik

Commendable
Feb 16, 2017
71
2
1,545
2
Thank you for the reply.

are you sure that you are saving the registry change?
No, I haven't been doing anything else than deleting the folder and closing the registry. I can't see any option to save this action in the registry itself - what do I need to do to make the change permanent?

What make and model keyboard?
Razer DeathStalker Chroma. I'm not sure it's a keyboard thing though - a lot of people with different setups have had this issue of Windows re-adding the US layout after they delete it.

Here are two screenshots displaying language-related settings while this is happening:

On screenshot one you can see three language inputs displayed in the language bar in bottom-left while display language settings should only permit two.
On screenshot two you can see admin settings for languages.
 

Ralston18

Titan
Moderator
Screenshot #2

Welcome Screen; "Input language could not be read"

Try checking and saving the two "Copy your current settings" boxes

My windows are consistent with respect to "Current user" , "Welcome screen" and "New user accounts". Location is US.

The windows in Screenshot #2 are mixed between English US and UK. I am not sure about the impact of Georgian QWERTY.

You might try changing the setting in "Language for non-Unicode programs" when you switch back and forth.

System locale - change from Georgia to UK.

Concern being that the registry might have invoked some "permanent" or "default" setting. Since you did not apparently save any registry changes hopefully those changes are moot.
 

Tornik

Commendable
Feb 16, 2017
71
2
1,545
2
I ticked the two boxes mentioned in the suggestion above and restarted. As I logged into Windows, the language bar had the two inputs I want but US input reappeared in there a few seconds later.
 

ASK THE COMMUNITY

TRENDING THREADS