Question USB devices randomly disconnecting and freezing up without disconnecting.

Jun 1, 2021
2
0
10
0
Hi all, this issue has been bugging me for weeks but only recently been worse. Almost all of my USB devices either freeze at random intervals frequently until I unplug them and plug them in again, or disconnect completely and reconnect themselves all at the same time. My PC also experiences crashes to BSOD as well as blackscreen restarts. The devices are plugged into different hubs such as monitor, main IO, top of case, and a PCIE to USB extension card, so I've pretty much ruled out the issue being certain ports. Going through the device manager and disabling "Allow the computer to turn off this device to save power" on all 17ish usb controllers does help to an extent, but has to be done after every restart as they enable themselves at random sometimes. Even now writing this though, my keyboard is missing some inputs or "sticking" on some. These issues happen both when there is no stress on a system or when there is, but more frequently when I am running a game etc. This is making me think that my power supply is possibly going bad rather than I am maxing it out as it is a 650w. Specs Below now.

Motherboard: B450 GAMING PRO CARBON AC
OS: Microsoft Windows 10 Home 64-bit Ver.2009 (OS build 19042.985)
BIOS Version: 1.C0
BIOS Release Date: 06/11/2020
CPU: AMD Ryzen 7 3700X 8-Core Processor
Memory: 32 GB @
- 8 GB DDR4-2133, Unknown CMW16GX4M2C3200C16
- 8 GB DDR4-2133, Unknown CMW16GX4M2C3200C16
- 8 GB DDR4-2133, Unknown CMW16GX4M2C3200C16
- 8 GB DDR4-2133, Unknown CMW16GX4M2C3200C16
Graphics: AMD Radeon RX 5700 XT, 0 MB

I shouldn't be maxing out my 650w PSU with those specs, but if it was failing and not producing enough wattage for my pc, that could explain the crashes and USB devices being turned off to save power, progressing into them freezing and restarting. Any ideas? I'm open to replacing either PSU or Motherboard, but would like to have some opinions / options to try before ordering something just to return it.

Edit: I have also ran Windows Memory Diagnostic to test my ram for any issues, as the issues seem to have gotten worse since I installed 16 more GB of ram (Increased watt usage taken from failing psu?). But got this log result. "The Windows Memory Diagnostic tested the computer's memory and detected no errors"
 

InvalidError

Titan
Moderator
If you haven't updated the BIOS in a while, check if there is a new update with the newer AGESA that improves USB stability.

The computer doesn't have any means to know what PSU is installed or what its ratings are, so it cannot know how close to maximum it is. The way a PC "finds out" that it has gone over the PSU's limit is when it trips a PSU protection and the whole thing shuts off altogether.
 
Jun 1, 2021
2
0
10
0
If you haven't updated the BIOS in a while, check if there is a new update with the newer AGESA that improves USB stability.

The computer doesn't have any means to know what PSU is installed or what its ratings are, so it cannot know how close to maximum it is. The way a PC "finds out" that it has gone over the PSU's limit is when it trips a PSU protection and the whole thing shuts off altogether.
Thanks for the response, I forgot to mention in my main post but yes, I did update my BIOS to the newest stable version released 06/11/2020 from a 07/09/2019 release. The only newer version is a Beta Version released 2 months ago, which is described as "Update to ComboAM4PIV2 1.2.0.2" I did not update to this due to the Beta Version warning as well as the description seemingly having nothing to do with USB stability.
Both Windows and my GPU are fully updated.

In regards to the PSU "limit" I was referring too, I am mainly guessing between the combination of the motioned BSOD / System shutdowns + restarts I've experienced recently while gaming and the ""Allow the computer to turn off this device to save power" device manager option helping a tiny bit. After system crashes, my Radeon Software gives me this notification "Default Radeon WattMan settings has been restored due to unexpected system failure" and I have to edit my fan speed maximum again.
 

ASK THE COMMUNITY

TRENDING THREADS