Question USB Disconnecting & Reconnecting

jacksonpetz44

Reputable
Oct 14, 2018
8
0
4,510
0
Hey so I decided to resort asking here. I'm having the issue of all of my USB devices disconnecting and reconnecting. All my parts are brand new as well.

What I've tried to do to fix it.
  1. BIOS fully up to date.
  2. Uninstalling/updating drivers in device manager.
  3. Turning off the power management in my device manager for my USB devices.
  4. Disconnecting all my power cables from the PSU to the MB as well as USB cables.
  5. Windows fully up to date. GPU drivers fully up to date.
  6. Anything that requires something need to be up to date is fully up to date.
PC Specs:
CPU: Ryzen 9 5950x
MB: ASUS ROG Crosshair VIII Dark Hero
GPU: EVGA FTW ULTRA 3090
RAM: 64GB 3600MHz Trident Z Royal
PSU: EVGA Gold + 1000w
CPU Cooler: NZXT Kraken X73
Storage: Samsung 970 EVO Plus 2TB M.2 & Seagate Ironwolf 4TB HDD


If anyone can think of anything else I could try. I am all hears I would love to try and get this to fix because I can't really do much without it happened. If I miss something that needs to be update or anything I'm all hears or if maybe I got a defective part that I may need to return.
 
Have you tried switching USB ports? Some USB ports on your motherboard are controlled by the Ryzen processor and others are controlled by the X570 chipset. Trying different ports could isolate your problem.

AMD Ryzen™5000 Series Processors :
4 x USB 3.2 Gen 2 port(s) (4 ports at back panel, Type-A [red])

AMD X570 chipset :
1 x USB 3.2 Gen 2 front panel connector port(s)
4 x USB 3.2 Gen 2 ports (4 ports at back panel, 3 x Type-A [red], 1 xUSB Type-C)
6 x USB 3.2 Gen 1 port(s) (4 ports at back panel [blue], 2 ports at front panel)
4 x USB 2.0 port(s)
 

jacksonpetz44

Reputable
Oct 14, 2018
8
0
4,510
0
Have you tried switching USB ports? Some USB ports on your motherboard are controlled by the Ryzen processor and others are controlled by the X570 chipset. Trying different ports could isolate your problem.

AMD Ryzen™5000 Series Processors :
4 x USB 3.2 Gen 2 port(s) (4 ports at back panel, Type-A [red])

AMD X570 chipset :
1 x USB 3.2 Gen 2 front panel connector port(s)
4 x USB 3.2 Gen 2 ports (4 ports at back panel, 3 x Type-A [red], 1 xUSB Type-C)
6 x USB 3.2 Gen 1 port(s) (4 ports at back panel [blue], 2 ports at front panel)
4 x USB 2.0 port(s)
Thanks for the reply I went ahead and put all of the USB cables on the X570 Chipset to see if the problem still continues and if it does then maybe I got a faulty MB you think? I plan on testing it on the CPU USB ports. I appreciate the reply and advice.
 

jacksonpetz44

Reputable
Oct 14, 2018
8
0
4,510
0
Have you tried switching USB ports? Some USB ports on your motherboard are controlled by the Ryzen processor and others are controlled by the X570 chipset. Trying different ports could isolate your problem.

AMD Ryzen™5000 Series Processors :
4 x USB 3.2 Gen 2 port(s) (4 ports at back panel, Type-A [red])

AMD X570 chipset :
1 x USB 3.2 Gen 2 front panel connector port(s)
4 x USB 3.2 Gen 2 ports (4 ports at back panel, 3 x Type-A [red], 1 xUSB Type-C)
6 x USB 3.2 Gen 1 port(s) (4 ports at back panel [blue], 2 ports at front panel)
4 x USB 2.0 port(s)
So I've tested both ports that were tested controlled by the X570 chipset and the CPU ports and the problem continues still I guess I should've added that I have brand new cables for all my USB devices that can have different cables. So maybe a motherboard issue and the problem still continues whenever I use the USB ports controlled by the CPU since maybe the motherboard is to blame. Both parts can be replaced for free so maybe just replace both the CPU and MB and see if I still get the issue.
 
So I've tested both ports that were tested controlled by the X570 chipset and the CPU ports and the problem continues still I guess I should've added that I have brand new cables for all my USB devices that can have different cables. So maybe a motherboard issue and the problem still continues whenever I use the USB ports controlled by the CPU since maybe the motherboard is to blame. Both parts can be replaced for free so maybe just replace both the CPU and MB and see if I still get the issue.
Looking through the past BIOS updates for your motherboard, version 3401 lists "USB connectivity issue" as one of the fixes, so it has been an issue for this motherboard in the past. You could email Asus customer/technical support and let them know you are experiencing a recurrence of this problem.

Version 3401 - 2021/03/20
ROG CROSSHAIR VIII DARK HERO BIOS 3401
- Fix USB connectivity issue
 

jacksonpetz44

Reputable
Oct 14, 2018
8
0
4,510
0
Looking through the past BIOS updates for your motherboard, version 3401 lists "USB connectivity issue" as one of the fixes, so it has been an issue for this motherboard in the past. You could email Asus customer/technical support and let them know you are experiencing a recurrence of this problem.

Version 3401 - 2021/03/20
ROG CROSSHAIR VIII DARK HERO BIOS 3401
- Fix USB connectivity issue
It seems even talking with them and their solutions the problem still continues I'm wondering if it is my best option to just return the motherboard and CPU you think and get them replaced with no charge
 

ASK THE COMMUNITY