Question USB Network adapter randomly gets disabled.

Apr 25, 2021
5
0
10
0
Hello,
I'm having a rather annoying issue where my external usb network adapter keeps getting disabled and I lose internet connectivity. I thought it was a defective adapter so I ordered another one that is a different model but both of them randomly gets disabled at the same time and I have to restart my computer for them to work again. I've checked for possible solutions but all I see are things like "rollback the system" or "reinstall the driver". The driver is a Windows embedded driver so it's not something from the manufacturer. Any ideas would be greatly appreciated! The event log is as follows:

The description for Event ID 17 from source AX88179 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

INT complete failed.

the message resource is present but the message is not found in the string/message table


- <Event xmlns=" ">

- <System>

<Provider Name="AX88179" />

<EventID Qualifiers="49152">17</EventID>

<Level>2</Level>

<Task>0</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2022-02-20T21:30:45.921029000Z" />

<EventRecordID>2918246</EventRecordID>

<Channel>System</Channel>

<Computer>Alienware</Computer>

<Security />

</System>

- <EventData>

<Data />

<Data>INT complete failed.</Data>

<Binary>000000000200280000000000110000C0000000519D0000C000000000000000000000000000000000</Binary>

</EventData>

</Event>
 

dwd999

Honorable
Did you open the Control Panel Power Options app and make sure everything setting is set to Maximum so that its not shutting anything off? Did you open the Device Manager and check to see that for all of the devices associated with the usb ports and network operations have the Properties, Power Management options to turn off the devices UNchecked?
 
Apr 25, 2021
5
0
10
0
Did you open the Control Panel Power Options app and make sure everything setting is set to Maximum so that its not shutting anything off? Did you open the Device Manager and check to see that for all of the devices associated with the usb ports and network operations have the Properties, Power Management options to turn off the devices UNchecked?
Thanks for the reply! I have it set for max performance already. And I just went through the USB Controller section of device manager and disabled any power management features. I hope this works.
 
Apr 25, 2021
5
0
10
0
Thanks for the reply! I have it set for max performance already. And I just went through the USB Controller section of device manager and disabled any power management features. I hope this works.
Still no luck. Both adapters keep getting disabled at the same time. Any other ideas?
 
Mar 29, 2022
1
0
10
0
I have the same issue over here, with the USB3.0 to ethernet adaptor AX88179. Since a few weeks, Windows 10 started reporting it as malfunctioning after a few minutes I plug it in. It works fine in other versions of windows. I have the feeling that a windows update caused this issue. Have any of you found a solution yet?
 
Apr 25, 2021
5
0
10
0
I have the same issue over here, with the USB3.0 to ethernet adaptor AX88179. Since a few weeks, Windows 10 started reporting it as malfunctioning after a few minutes I plug it in. It works fine in other versions of windows. I have the feeling that a windows update caused this issue. Have any of you found a solution yet?
No. I'm still having this issue. Device manager totally removes both adapters from the hardware listing and the only way to get it working again is to reboot the computer which is a total pain. If I come across anything I'll post it here but I've been having this issue for a while now with no hint of a solution.
 

ASK THE COMMUNITY