Question When waking from sleep, the first key command is transmitted to the OS, any way to do the opposite like in macOS ?

Apr 6, 2021
18
3
15
0
Always come back and hit space and pause my Spotify. I know from the start that Windows has been like this, but I like macOS's style better on this.
 
Apr 6, 2021
18
3
15
0
So on Mac OS it pauses the APP but on Windows it just wakes windows?

there is an app for the lock screen, not sure if that helps - https://community.spotify.com/t5/Chat/Spotify-now-has-player-controls-on-Windows-10-Lock-Screen/td-p/1484936
Oh my, looking back, I realize I used improper terms in many places. And I should have clarified what I meant by opposite.

On windows, if you leave your computer and the display sleeps(not sleep mode) if you press space, or any key, that key is transmitted to the window that is open. say you're copying a large transfer, just pressing space will pause or sometimes cancel it. Because I had Spotify open it would pause my music.

On macOS, if you leave your computer, and the display sleeps, the first key or click you send, will not affect any application or window that is open. It will only "wake" the computer or turn on the display. This makes more sense.

A temporary solution is to move the mouse instead - but here's the weird part, moving the mouse doesn't wake the display on mac lol.
That's not my goal right now however. As of now I would just like windows to ignore that first key returning from display sleep (which the OS is doing not the monitor itself)

Thanks,
Trip
 

Colif

Win 10 Master
Moderator
wonder if setting a screensaver in windows would change what it does with the 1st press.
right click desktop
choose personalise
choose lock screen
click the link at bottom for Screen saver settings

I would just chose blank screen if you don't want anything else
choose its timer period and maybe tick On resume, display log on screen
then when you tap a key it will show lock screen instead of anything other action
 
Apr 6, 2021
18
3
15
0
wonder if setting a screensaver in windows would change what it does with the 1st press.
right click desktop
choose personalise
choose lock screen
click the link at bottom for Screen saver settings

I would just chose blank screen if you don't want anything else
choose its timer period and maybe tick On resume, display log on screen
then when you tap a key it will show lock screen instead of anything other action
Hey thanks for the reply @Colif. Took some time to test. Yes it seems that solves the problem while the screensaver is on, but after 5 minutes, the screen itself is "put to sleep" (by the OS) and then the same behavior again is prohibited

Alternatively you could press another key that usually nothing to the app by itself but is considered a keypress, like Ctrl, Windows, or Alt.
Yeah...that seems viable. There's just something satisfying about coming back, hitting the big ol spacebar, and everything illuminates for you. Not the same effect with CTRL or ESC.
I'm still baffled windows performs this way tbh. Have I mentioned the mouse move works, but on Mac it doesn't! So there isn't one solid solution I can adopt. Maybe pressing yea, shift or something...
 

ASK THE COMMUNITY

TRENDING THREADS