Question Would Appreciate Some Help

Mar 23, 2019
2
0
10
0
So I started a new PC build today (2nd build ever, first in about 4 years) and I seem to have run into a wall.
Specs: Asus ROG Strix z390-e LGA 1151, Asus rtx 270, i7-9700k, Trident Z RGB 16gb, Corsair RMX 850 80+ Gold, NZXT kraken and a NZXT h500i
So I finish putting everything together and the first thing I notice is that pressing the power button on the case doesn't do anything. The RGB lighting on the mobo (by the IO shield) works, as well as the two small lights on the GPU, where the cables connect. I have since pulled everything out of the case and tried to do everything out of the case, but still I get the same results. I have tried a different power supply, different ram configurations, no GPU, and tried re-seating the CPU. Same exact result every time, with the only sign of life being that the RGB lights on the mobo light up. I'd really appreciate any help on this one, pretty tired of pulling my hair out over it.
 
Double check the case header cables are connected to the motherboard properly and in the correct location, each case labels the power switch wires differently but it should be something similar to "Power SW" you need to make sure its connected in the exact correct location and that you double check the motherboard manual for the correct location. The same is true for the other wires that come from the case such as Reset, HDD LED, etc. But if Power SW is in the wrong location the system will not attempt to boot.

If you confirm your version of the "Power SW" cable is indeed in the correct location then follow Alexoiu's advice and remove "Power SW" and short the pins yourself. If you are not sure how to do this, there are youtube videos that show the procedure.
 

ASK THE COMMUNITY