Question Adjusting i5-10600K clock

overclocler14

Reputable
Jan 20, 2017
41
0
4,530
0
I recently upgraded my old, bottlenecked PC to another bottlenecked PC but it is much better, and I'm saving for some decent GPU. I got an i5-10600k a Z490-A PRO motherboard and an AiO cooler from MSI (MAG CoreLiquid 240R) for future overclocking.

The problem is although the CPU is not doing anything most of the time (even in games it sees around 20% usage) it sits at full clock almost all of the time. I want it to throttle down to save some power when it sits idle . Howewer even slightest load (less than 5%) causes it to jump to around 4 GHz or sometimes even the maximum 4,8.

How I should configure the BIOS not to run it at full power and force it to utilise higher C-States? It should support up to C10 but it only uses C2 at best.
I tried playing with the QuickCPU tool and it does work to some extent, but was necessary to run the program at startup and set lowest power setting which also created custom power profile in Windows. I then modified the "High performance" profile myself and now it shows lower clocks that sometimes briefly go as low as 0,8 GHz and leaves only 2 cores active and parks the rest.

I wouldn't complain but I want it to unpark the cores while gaming and only then allow it to achieve higher clocks. Is it even necessary for me to use any kind of Turbo boost, or should I rather downclock it for now to deafult 4,1 GHz or lower and then it would be less chaotic with clocks? I think for now I won't use its full capability anyway.
I remember that almost everything in the OC section of my motherboard is set to Auto, so it should automatically adjust the clock, also no OC Genie is enabled, (it seems to set a fixed high clock with absolutely no power saving features). Only XMP is active to allow my RAM to run at 3600 MHz.

PS I also have some questions about the temperature since I never used water cooling before, but I'll create another thread for it after I manage to resolve the clock issues I described here.
 
Do you see it fluctuating around 800, to 1000-2000 MHz when merely loafing at the desktop?

Leave Turbo-Boost enabled.

It will ramp up clock speeds on one or more (or even all) cores as you do things like open/close applications, which is normal as long as you are in Balanced Power Plan, and have not tinkered with setting fixed multipliers, using Default. (If you mainboard supports MCE, if /when that is enabled, the CPU will try to hit max turbo on all cores under load if cooling and power budget permit.)

Messing with core parking/assignments is just exploring down a rabbit hole of wasted time.

Thus far you've described 100% normal operation as 'chaotic clock speed issues', and have not really given a problem yet.
 

overclocler14

Reputable
Jan 20, 2017
41
0
4,530
0
I thought it should have lower clocks when doing nothing, similarly to a GPU (which depending on chip drops as low as 140-ish MHz). Instead it jumps around 3,8-4,8 GHz. I reset all power plans to deafult a couple of times, enabled the balanced one and it seems to work, now the clock fluctuates between 1,5 and 4 GHz. Left all cores unparked if it doesn't make sense to disable them at idle.
 

ASK THE COMMUNITY