Question All Games crashing PC and "No signal" displaying on monitor

Nov 22, 2021
5
0
10
0
Hello,

My 1 week old PC has been crashing during game play, these games could be higher demanding games like Skyrim or low demanding games like Runescape. The PC will crash in a few different ways:

-The screen goes black mid game, no messages pop up. "No signal" does NOT appear on the screen this time, the screen is just black. Trying to launch task manager sometimes shows some windows beginning to open but the screen ends up returning to the blank black state. I've waited this out for about 10 minutes and so far it doesn't correct it self. I have to shut down and reboot the PC with the button on the tower.

  • When launching Skyrim, the game freezes on the load screen before the log in screen of skyrim even shows up.
  • When launching Skyrim, the load screen is extremely laggy, I can't even use the mouse to exit because the lag is so bad.
- During boot up, the monitor displays the regular ACER logo and other gaming logos. But when it gets to the point to display the log in page, "No signal" is the only thing that is showing on the screen. In the top right corner of the screen, I can see the monitor displaying HMDI1, HMDI2, DPI etc.
I have no choice but to hard shut down and reboot again. I usually have to reboot once or twice like this, and then all of a sudden I am able to see the log in screen and proceed to log in without issues.
I have tried changing HDMI ports on the PC and the monitor. I tested the monitor with another system when this happens and it works fine.

- The PC Freezes, the picture becomes slightly distorted with lines going through the screen. I have no option but to hard shut down and reboot again.

- The screen has very clear lines going through the entire image of my 32inch screen. I have to reboot through the power menu.

- A couple times when i open nvidia geforce experience, the nvidia window appears.... glitchy and its like some blotches of the screen didn't load properly. Hard to describe. I have to reboot through the power menu.

Also when I do let the PC sit with a black screen or black screen + "No signal" being displayed on the screen, the PC fans start going really fast and it's very loud. Not sure if it's just one fan or all of them.

Sometimes I am able to play games for a couple hours before an issue occurs. Other times I can't play for 5 minutes.

I have heard a windows chime go off when the game/PC is crashing, but I'm unable to see any errors since the screen becomes unusable.

I've reinstalled windows
I've reinstalled the games
I've paid for Driver Easy to update and install all drivers
My nvdia drivers are all up to date

What are the next troubleshooting steps I could take? This is my first desktop PC, and I am still using my laptop from college 8 years ago. I am not that well versed in the more advanced PC terminology yet so I apologize if I need to ask for clarification of simple instructions.

This is the PC I received last Tuesday: https://www.newegg.ca/abs-ali560/p/N82E16883360190?item=N82E16883360190
 

logainofhades

Titan
Moderator
I would be calling getting with newegg, on this, since it is new, and ABS is their house brand. You can go an check all the wiring connections, to make sure they are secure. What is the make/model of the power supply they put in it? Also that cooler is inadequate for the CPU.
 
Nov 22, 2021
5
0
10
0
I would be calling getting with newegg, on this, since it is new, and ABS is their house brand. You can go an check all the wiring connections, to make sure they are secure. What is the make/model of the power supply they put in it? Also that cooler is inadequate for the CPU.
I believe its a Vega PSU. By cooler you mean the main fan above the GPU? The Cool Master fan?

Also newegg doesn't trouble shoot as far as I know. I'm trying to avoid returning this if there is a fix. But I have started a conversation with Newegg about this yesterday to see if they can offer any advice.
 
Nov 22, 2021
5
0
10
0
They may ask you to just RMA it. Yes, on the fan.
I'm kind of nervous about shipping it back too. Since if anything goes wrong with the delivery, it'll be on me and I could be out a PC.

I don't have the tamperproof type of tape the PC was sent to me with either. Do you have any experience with this or words of wisdom for me?
 

ASK THE COMMUNITY

TRENDING THREADS