Question (AMD Radeon R2) New 4K monitor flashes on end

Aug 24, 2019
8
0
10
0
(I've linked a video of the issue down below)

I'm using a 20 months old HP 255 G6 laptop, with an AMD Radeon R2 display adapter, and an internal screen resolution of 1366768 px, running Windows 10 (version 1903, OS Build 18362.535). I've used an older external monitor with a resolution of 19201080 px (connected to the laptop with an HDMI cable) for a long time, without any problems whatsoever.

Now I bought a used external monitor (Samsung U28E590D) with a resolution of 3840*1080px. It's in perfect physical shape, and when it's not plugged into the laptop, and I use the handle an the back (which also acts as its power button), the menu is displayed just fine, and there are no issues. That's why I assume that the monitor is working, and that the following problem is with my computer, probably with the display adapter.

Before I actually looked at the entire back as I should have done in the first place, and the monitor was connected to the PC (also via HDMI), I used the CD that came with it to install the software that let me install the correct driver (Screenshot of the menu: https://drive.google.com/file/d/16LlxoGJRgo5quqrEHeMKraIHhyhqkzq5/view?usp=drivesdk ). The selected option is the one I installed. The first part is the monitor model, the second part is the port the cable is plugged into (Photo of the ports: https://drive.google.com/file/d/16OXbkhamICqhOy2aQiV_b3WGVcnc2Wff/view?usp=drivesdk ). Then I found the button/handle (shortly before that, I hit Win+P, and selected duplicate as the projection option). Both screens showed the cursor on a black background for about two seconds, a black screen for the same time, repeated this about five times, and the external monitor turned itself off, and the internal one went back to normal. Win+P now said something along the lines of "This monitor can't be projected". I thought there was a driver issue, so I went on the AMD website and downloaded their tool called "AMD Radeon Software Adrenalin 2020 Edition". Nothing changed. Tried updating the display port driver inside Device Manager, unsuccessfully. Ran Windows Update, restarted my PC. Nothing changed. The AMD application showed that there was a "Driver/Software" update available. I downloaded and installed it. Got a notification from it that said I should enable Virtual Super Resolution, and I did. The issue still persisted, but at least now, while the external monitor flashed, at times the taskbar showed up at the bottom, now in the correct 4K resolution (I set Win+P to Extend some time earlier), but now the flashing went on in a seemingly endless loop (Video of the flashing at this point: https://drive.google.com/file/d/16GbkT254b6vUd1QjacHJpLeH0WYGT-Wr/view?usp=drivesdk ). And even though Device Manager thinks that the monitor (which is plugged in, and off) is connected, the "Easy Setting Box" application (also from on the beforementioned CD), which I didn't get beyond this error message even a single time today, says "Samsung Monitor not found". In Device Manager, the AMD Radeon R2 Graphics display adapter showed a code 43 error message after I first plugged in the monitor, but it's gone since I installed the application. Its driver version is now 26.20.15015.1007, and the monitor's driver version is 1.0.0.0 (I checked on the Samsung website, this is still the most recent version).

If anyone knows how to solve this, that would be greatly appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS