[SOLVED] Asus TUF Z490-Plus - Can't See UEFI BIOS Screen - But Boots Fine to Windows

Sep 17, 2020
Hello everyone! Not sure if this has a solution, but I reaally don't really want to go through all the trouble of RMAing it...

The thing is, after switching HDMI ports between the GPU plug and the motherboard plug (integrated graphics) while inside the BIOS, I can't reach/see the BIOS anymore.
However, it boots just fine! If I don't press F2 or Del to access the BIOS, it works just fine, and it boots to Windows as if everything was working perfectly fine, no issues, no flags, nothing.
But as soon as I do press F2 or Del to access the BIOS, the screen turns black (really, just black, it HAS input signal, but it doesn't display anything).
F8 during startup to show the boot devices is working fine as well.

This is really peculiar!

Motherboard: Asus TUF Z490-Plus
CPU: i7 10700k
GPU: GTX 970 (I know, I'll be upgrading soon!)
Monitor: Philips 27" 4K (HDMI / Display Port)

I've tried:

  • Integrated Graphics Only
  • GPU only
  • Both Integrated Graphics and GPU connected at the same time
  • All of the above in a different monitor (1080p) using the same HDMI cable.
  • All of the above, in a different monitor (1080p), using a DVI cable.
  • Resetting the CMOS by taking the battery off the motherboard
  • Resetting the CMOS by removing the battery AND shorting the CLRTC pins
  • Changing the default resolution of my display through my Nvidia Control Panel to match the BIOS settings
What I didn't try:

- Updating/refreshing my BIOS - for that, I NEED to access the BIOS (Easy Flash or something), can't do it through Windows apparently, thanks Asus.

I'm lost! I hope you guys can give me some light. Thank you!!!