Question Audio from Sound Blaster G6 disconnects ?

artavasdes

Prominent
Nov 28, 2019
91
6
565
11
I have sound blaster g6 and it disconnects usually whenever I tab out or into a game/application that has audio. It also sometimes randomly disconnects. The headphones I use it with are Beyerdynamic dt 990 pros.
Thanks for any help!
 

delaro

Splendid
Ambassador
Not much can cause that.

Unplug the unit and uninstall all drivers along with Soundblaster Command.
Install Soundblaster Command and then plug the unit in and allow Command to install and update Creatives drivers and firmware.

If that doesn't work then disable USB selective suspend feature from your energy plan.
 

artavasdes

Prominent
Nov 28, 2019
91
6
565
11
Not much can cause that.

Unplug the unit and uninstall all drivers along with Soundblaster Command.
Install Soundblaster Command and then plug the unit in and allow Command to install and update Creatives drivers and firmware.

If that doesn't work then disable USB selective suspend feature from your energy plan.
I disabled the energy suspend feature yesterday and it has been working fine now. I will uninstall the drivers and reinstall just to make sure.
 

artavasdes

Prominent
Nov 28, 2019
91
6
565
11
Not much can cause that.

Unplug the unit and uninstall all drivers along with Soundblaster Command.
Install Soundblaster Command and then plug the unit in and allow Command to install and update Creatives drivers and firmware.

If that doesn't work then disable USB selective suspend feature from your energy plan.
Not much can cause that.

Unplug the unit and uninstall all drivers along with Soundblaster Command.
Install Soundblaster Command and then plug the unit in and allow Command to install and update Creatives drivers and firmware.

If that doesn't work then disable USB selective suspend feature from your energy plan.
I ended up uninstalling the drivers and did the steps you listed, but the problem still continues, it is most likely a hardware issue.
 

ASK THE COMMUNITY