Question CPU fan does not spin. NO POST

May 20, 2019
12
0
10
0
Hello everyone!

I recently had a fried motherboard. So I decided it was time for new components (previously 9 year old build).

I brought a new PSU (MAXPRO 750w), new mobo (ASRock AB350 Pro4), New CPU (Ryzen 5) and a new stick of ram to go with the new board (Crucia Ballistix Sport 8gb DDR4).'

When I Start the computer, it sounds normal and boots up. The only thing not running is the CPU fan, and thus the PC restarts, presumably because of the Fan, and never posts.

I already have tried Plugging the fan into the Cha_Fan with no luck. The computer apparently Posts and works when I connect my old intel Cpu Fan to the board, but I am too scared of overheating the cpu to go into bios and so on.

What should be done?

Thanks!

PS. the CPU Fan is a Wraith Stealth
 
May 20, 2019
12
0
10
0
witch ryzen 5 you have if it is not a apu system wont boot you need a gpu .
Sorry, I forgot to say, I saved my GPU and Hard disk, case, and so on.
So I am running with a GPU(Raddeon R7950), all fans are also running GPU, Case and PSU, all except the CPU fan.
 

rookieGamer

Commendable
May 16, 2017
201
15
1,715
8
so you say you just bought that CPU 'new'.. and the stock fan stopped working. but when you plugged in another fan in same socket that other fan worked.
every heard of thing called warranty ?
 
May 20, 2019
12
0
10
0
find a way to test the cpu cooler fans in another system as case fans it could be defective .
My suspicion is that is defective out of the box, would not be ones first thought with amd tho,
so you say you just bought that CPU 'new'.. and the stock fan stopped working. but when you plugged in another fan in same socket that other fan worked.
every heard of thing called warranty ?
  • I brought the AMD Ryzen 5 with wraith cooler.
  • wraith cooler doesn't work when plugged in. Also doesn't work as case fan
  • Cpu works and boots with old intel cpu cooler attached.
it didn't stop working, it didn't work out of the box. Box Fresh!
 

rookieGamer

Commendable
May 16, 2017
201
15
1,715
8
My suspicion is that is defective out of the box, would not be ones first thought with amd tho,


  • I brought the AMD Ryzen 5 with wraith cooler.
  • wraith cooler doesn't work when plugged in. Also doesn't work as case fan
  • Cpu works and boots with old intel cpu cooler attached.
it didn't stop working, it didn't work out of the box. Box Fresh!
again there is thing called 'Warranty'. ship them your CPU+box+stock cooler (keep the stickers :devilish:) and get a replacement
 

ASK THE COMMUNITY

TRENDING THREADS