Question i5 2500 Dell Optiflex 790 SFF not using Turbo Boost

Jun 14, 2019
16
0
10
0
Hey guys, i have an Optiflex 790 SFF with an i5 2500 but i noticed recently that it does not go above 3.28Ghz under load, no matter if its gaming, synthetic benchmarks, i've tried setting the stress tests for 1 thread, 2 threads, 3 and 4 and i still have no Turbo Boost being activated.

PS: I have Turbo Boost enabled in the BIOS as well as " Intel Speed Step ".

I have also noticed that task manager says the Base speed is 3.29 instead of 3.30, i know its not much but is it normal to show a little less?
 

jay32267

Distinguished
Have you checked to see if windows power plan setting is set to "high performance"?

  1. Go into Power options *(Control panel -> Hardware and Sound -> Power Options) and click *Change plan settings near your plan (e.g. I use high performance for CPU intensive tasks, such as gaming).
  2. Then click on Change advanced power settings.
 
Jun 14, 2019
16
0
10
0
Have you checked to see if windows power plan setting is set to "high performance"?

  1. Go into Power options *(Control panel -> Hardware and Sound -> Power Options) and click *Change plan settings near your plan (e.g. I use high performance for CPU intensive tasks, such as gaming).
  2. Then click on Change advanced power settings.
I was using balanced but even in high performance there's no boost, this pc had previously an I3 2120 which doesn't support turbo boost, maybe i should update my BIOS?
 

jay32267

Distinguished
I was using balanced but even in high performance there's no boost, this pc had previously an I3 2120 which doesn't support turbo boost, maybe i should update my BIOS?
It's something to try....but I would only do it as a last resort.

Have you tried this?

Enabling or disabling Intel Turbo Boost Technology
  1. From the System Utilities screen, select System Configuration > BIOS/Platform Configuration (RBSU) > Performance Options > Intel (R) Turbo Boost Technology and press Enter.
  2. Select a setting and press Enter.
    1. Enabled—Enables the logical processor cores on processors supporting hyperthreading technology.
    2. Disabled —Reduces power usage and also reduces the system’s maximum achievable performance under some workloads.
  3. Press F10.
 
Jun 14, 2019
16
0
10
0
It's something to try....but I would only do it as a last resort.

Have you tried this?

Enabling or disabling Intel Turbo Boost Technology
  1. From the System Utilities screen, select System Configuration > BIOS/Platform Configuration (RBSU) > Performance Options > Intel (R) Turbo Boost Technology and press Enter.
  2. Select a setting and press Enter.
    1. Enabled—Enables the logical processor cores on processors supporting hyperthreading technology.
    2. Disabled —Reduces power usage and also reduces the system’s maximum achievable performance under some workloads.
  3. Press F10.
Tried both Enabled and Disabled, still no boost, and F10 doesn't seem to do anything in the bios...
 

jay32267

Distinguished
That's all I can think of at the moment.
If I was at the point where I tried everything I could....and I still wanted Turbo Boost enabled....I would do a BIOS update.
But here's the thing....if I didn't absolutely need Turbo Boost....I would leave it alone.
 

ASK THE COMMUNITY

TRENDING THREADS