Question Intel660p not detected on Asrock X570 ITX

Apr 7, 2021
4
0
10
0
Hello & thank you in advance for any help.

I've recently built my 4th PC, which is intended to be a lightweight ITX build for music production.

I've elected to use just one drive, which is the Intel660p 512gb M2.

When I boot, my X570 ITX UEFI can't seem to recognise the drive. If I boot through Windows install USB I also cannot locate the drive.

I'm pretty lost, have tried removing and reinstalling the drive as well as fiddling with some settings in UEFI but I'm not very proficient in it.

Any help greatly appreciated!

Thanks
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Which BIOS version are you currently on for your motherboard? When you speak of the installer for the OS, did you fabricate your bootable USB installer using Windows Media Creation Tools? Make and model of the case you're working with?

On second thoughts, please list the specs to your entire build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:pSU:
Chassis:
OS:
 
Apr 7, 2021
4
0
10
0
Welcome to the forums, newcomer!

Which BIOS version are you currently on for your motherboard? When you speak of the installer for the OS, did you fabricate your bootable USB installer using Windows Media Creation Tools? Make and model of the case you're working with?

On second thoughts, please list the specs to your entire build like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:pSU:
Chassis:
OS:
Thanks for the quick response!

CPU: AMD Ryzen 5 pro 4650g (OEM)
Motherboard: Asrock X570 ITX/TB3
Ram: PNY XLR8 32GB (2x 16GB) DDR4 3200MHz Memory
SSD/HDD: Intel 660p 512GB M.2 PCIe NVMe 3.0 x4 3D2 SSD
GPU: Nil
PSU: Corsair SF450 450W 80 Plus Gold Full Modular SFX Power Supply
Chassis: SilverStone Sugo SG06-LITE Mini ITX Case
OS: Windows 10 Home

BIOS version 2.30 - I did not fabricate my bootable USB installing using Windows Media Creation, I bought it retail.
 

ASK THE COMMUNITY