Question iRST - Boot Screen

Jan 21, 2021
2
0
10
0
Hi All,

I've been getting really frustrated with this issue: Intel Rapid Storage Technology shows up on every boot and drags out the boot time by about 4-5 seconds.

This all occured after receiving my serviced Samsung 970 EVO, which I sent back for a warranty claim.

First I had the Issue of the "newly serviced" 970 not wanting to boot at all, because of iRST. The issue was initiated by changing the boot option from AHCI to RAID (in my case iRST on the ASUS Z370-f mobo).
Upon changing, the system asked me to setup a raid configuration with my Samsung 860 SSD all the time, and wouldnt allow my 970 to boot at all. After removing all SATA cables and drives from my PC, setting windows to safeboot via CMD, it finally allowed me too boot from my m.2 970.

It now boots just fine, but I still get the iRST screen for about 1s on every startup. I can press "ctrl + I" to enther the raid setup, but I cant close it. I can only chose a drive to enter raid 0, or continue to boot. No other option is given.

I know 4-5 seconds is not a big deal, but it really annoys me.

Any suggestion on how to get rid of it without reinstalling Windows for the fourth time would be greatly appreciated! TIA!

:)
 
Last edited:

popatim

Titan
Moderator
Why did you enable raid? iRST is intels Raid controller software and enabling raid in the bios causes iRst to invoke at boot time to have the raid array work and be bootable.
If you don't need it turn it off.
 
Jan 21, 2021
2
0
10
0
I have to enable it to use the 970 EVO m.2 NVMe. It wont work with AHCI :/ If I understand correctly, AHCI only works with SATA?

edit: My bios (Asus Z370-f) only has two options: AHCI or iRST with Optane
 

ASK THE COMMUNITY

TRENDING THREADS