[SOLVED] Issue with Samba sharing from Raspbian and windows 10

onlythefreshness

Honorable
Jun 5, 2015
72
0
10,640
1
Currently I'm trying to connect my rp4 to my windows 10 share file but I'm running into quite a few issues. I want to say too that I'm quite a novice when it comes to non-windows based machines so there may be some errors in my operation that I'm unable to see.

Okay so I followed this guide exactly. https://www.raspberrypi.org/documentation/remote-access/samba.md
I'm stuck at where I need to enter:

Sudo mount.cifs //<hostname or IP>/share /home/pi/Windows hate -o user=<name>

I entered the correct IP for my windows machine, the same user name for user and now I'm being prompted for a password. I tried my windows account password, my windows used password to log on to my PC, my rp4 password and none of them worked. I get fed back an error saying "mount error (13): Permission denied".

I looked this up and I'm not finding any answers for this issues that I clearly understand also tried a few workarounds suggested from the community such as adding "sec=none" or "sec=ntlm" at the end after the username tag but unfortunately I get a different error being "mount error (22): Permission Denied".

I'm at a loss and would greatly appreciate any suggestions and help from any of you.
 

onlythefreshness

Honorable
Jun 5, 2015
72
0
10,640
1
Okay I found out the solution for myself not too long after posting this question. Windows 10 is a bit funny and was cutting off most of my PC's name when viewing it so I was a couple characters short when entering it for my Sudo command.

Anyone struggling in the future and reading this, always see what the full name is for your PC in the controll panel under "System" no matter how short or long you remember the name being.
 

ASK THE COMMUNITY