Question Issues installing network adapter driver

May 22, 2019
2
0
10
0
So, I’ve known that my pc has some kind if problem installing drivers, specifically network adapters for a while. NordVPN didn’t work because the driver wouldn’t install and same with Hamachi but that wasn’t of too much importance.

But yesterday, I tried updating the driver and it just stopped working.

I’ve tried everything I can think of. Reinstalling previous drivers, downloading the driver from the motherboard’s manufacturer (specs below) on another computer of course and nothing. When I try reinstalling previous drivers, the installation process times out (and I have tried increasing the time to time out)
When I try installing the official driver from the site, it says “The Realtek Network controller was not found. If Deep Sleep Mode is enabled, Please Plug the Cable”.

I’ve also tried both of these things in safe mode and even an app called “Driver Easy” (Seems kind of crappy tho).


I’m running: Windows 10 Pro (Version 1803)

My mobo: Gigabyte 970A-UD3P Rev.2

Network Adapter: Realtek PCIe GBE Family Controller

Any ideas as to what I can do to fix this? I’ll be happy to answer anything that may help fix this
 

ASK THE COMMUNITY

TRENDING THREADS