Question Laptop running slow, dropping frames but performance is showing low usage

May 13, 2019
10
0
10
0
Hey everyone so I've been having issues with my ASUS Ultrabook the model is UX501J, so I had to have the charging port repaired recently and since the repair the computer has been running sluggish. I've tried running games like Planet Coaster and Minecraft but have seen my FPS running well below the normal level (0-35 when they normally were over 70). So far I have tried updating drivers for my graphics card (I have my Nvidia card set as the default for all the games I run), windows, rebooting and have even done a full reinstall to windows which has seemed to improve the situation however not returned the computer to the original performance. Before the windows reinstall it was struggling with multiple chrome tabs. I run my games plugged in to my charger and on high performance battery settings. Checking through task manager and resource monitor it seems that everything is running well below their capacity during these drops. The biggest concern is that my computer has never struggled to run these games and now feels like its aged years.

Specs:
Nvidia Geforce GTX 960M
Intel HD Graphics 4600
Samsung MZHPV512HDGL SSD
Intel Core i7-4720HQ CPU @ 2.60GHz
 
May 13, 2019
10
0
10
0
check cpu/gpu temp?
ram/ssd usage?
what speed is the cpu running?
My temps have run at the same temps typically staying around the 75 to 85 area, my ram and ssd sit low on the percentages with my ram barley hitting 28% and my cpu speed is typically sitting blow the base speed
 

ASK THE COMMUNITY

TRENDING THREADS