Question low internet connection on high CPU usage

Dec 29, 2020
5
0
10
0
So I have this weird problem where my internet connection goes from 1000mbps to 50mbps when my CPU usage is above 90% (single thread). I wonder if this is a known issue because I can't seem to find anything about it online. Also if someone has a solution that would be great!

Here's my specs on a benchmark for references : https://www.userbenchmark.com/UserRun/44562038
 
for fast internet you need free CPU resources, network card offloads lots of stuffs to CPU, you can change that in network adapter settings
open device manager and go to network cards, open it and under advanced change following:
  • ARP Offload
  • Offload Receive IP Checksum
  • Offload Receive TCP Checksum
  • Offload TCP Segmentation
  • Offload Transmit IP Checksum
  • Offload Transmit TCP Checksum
  • IPV4 Checksum Offload
  • Large Send Offload v2 (IPV4)
  • Large Send Offload v2 (IPV6)
  • Receive-Side Scaling
  • TCP Checksum Offload (IPV4)
  • TCP Checksum Offload (IPV6)
  • UDP Checksum Offload (IPV4)
  • UDP Checksum Offload (IPV6)
  • Interrupt Moderation

not everything may be present, if its there, set it to disabled
 
Dec 29, 2020
5
0
10
0
for fast internet you need free CPU resources, network card offloads lots of stuffs to CPU, you can change that in network adapter settings
open device manager and go to network cards, open it and under advanced change following:
  • ARP Offload
  • Offload Receive IP Checksum
  • Offload Receive TCP Checksum
  • Offload TCP Segmentation
  • Offload Transmit IP Checksum
  • Offload Transmit TCP Checksum
  • IPV4 Checksum Offload
  • Large Send Offload v2 (IPV4)
  • Large Send Offload v2 (IPV6)
  • Receive-Side Scaling
  • TCP Checksum Offload (IPV4)
  • TCP Checksum Offload (IPV6)
  • UDP Checksum Offload (IPV4)
  • UDP Checksum Offload (IPV6)
  • Interrupt Moderation

not everything may be present, if its there, set it to disabled
Thank's for the advice, I just did it. Sadly, the problem persist. Somehow, my internet connection seems to get slower and slower as my computer stays on... It seems odd to me so I thought I would mention it.
 
Dec 29, 2020
5
0
10
0
you didn't mention your modem / hardware.
could be a Puma 6 chipset issue...
could be you're uploading a load of Windows telemetry
some sites download mining scripts as part of their payload.
I just did a clean boot and fixed it.. should have thought of it earlier
 

ASK THE COMMUNITY