Question MBR removed and cannot replace, cannot find Windows10

May 18, 2020
4
0
10
0
I was combining two partitions on my hard drive and inadvertantly removed the MBR, or swap, or whatever it was on that 500mb partition that I thought wasn't necessary anymore.

I've created a flash drive with Windows 10 on it to access the repair tools, went into CMD and used bootrec /fixmbr , bootrec /fixboot , bootrec /rebuildbcd

The first two worked, or so it said, but rebuildbcd had no effect.

Then i went through the process or reassigning the drive letter using diskpart and attempted /rebuildbcd again and i'm still getting the message saying there's 0 installs of windows on the machine.

I seemed to have followed all the instructions provided to me from several credible websites and I'm still not able to log back into my machine.

I have over 60gb of photos/videos on here that I absolutely do not want to lose. I mean I JUST moved them off my phone onto the hard drive before this happened.

Please help, I've dual booted before (not on this machine), I have other tools Gparted. Any direction and help would be appreciated. Thank you in advance.
 

howtobeironic

Respectable
Jun 16, 2018
318
19
1,915
31
Reinstalling windows is an option but let's see other ways to accomplish this. I assume that bootrec /rebuildbcd returns no OS's, you have tried the automatic repair function, and you have already taken a backup of the things you value. It's not likely for you to lose any data for editing boot configuration but this might even be a sign of a dead drive's last moments. Seriously, backup. If things go south you'll need a backup. I recommend Macrium Reflect for this. You can install that to another PC and create a bootable USB there to backup your drive.

First things first, we should know what disk is what letter. You already know how to ge to the recovery cmd panel, so get there. Now, one by one, execute these commands, one at a time:
diskpart (Might take a few seconds to initialize)
list vol (Lists current volumes on the PC, you are looking for the letters of the drive with 500 MB of space and the label "System Reserved", most likely C, and the main Windows drive, should have the space you see everyday and have the letter D. Note these down. Just in case you can't see a letter next to a specific partition, use select vol X where X is the number next to it, and then assign Y where Y is a letter not taken by any other drive, I will assume System Reserved as C and Windows drive as D)
exit (exits diskpart)

Then, let's scan the drives for errors before we start up. This will lessen the problems you might run into in the next step.
chkdsk /f x: where x is the drive letter for those drives. If you get errors run chkdsk /r x:, you might need to leave this overnight though

With that out of concern, we can start working on the BCD. The first action we will attempt is to leave bootrec no choice but to completely rescan all the drives by moving the BCD away from where it is. Right now, it's acting lazy.

bcdedit /export c:\bcdbackup (backs up the current BCD)
attrib c:\boot\bcd -h -r -s (removes the write protection on the BCD file)
ren c:\boot\bcd bcd.old (renames the BCD, making it inaccessible by bootrec)
bootrec /rebuildbcd (forces bootrec to do a full scan and rebuild the whole BCD, if it finds an installation, great, add it and you're good to restart)

If this fails to work, we'll try writing the BCD ourselves. The link is here, but I'll also walk you through if you ask: http://woshub.com/how-to-rebuild-bcd-file-in-windows-10/
 
May 18, 2020
4
0
10
0
They were moved.

I'm trying to run a live version of Ubuntu at the moment because it seems the simplest of the options. Problem has already arisen though.

I created the live usb for ubuntu on this old laptop that I'm using to write this up. I plug it in on the new (computer with partition issues) computer's usb port on the front, fire it up, I am greeted with a GNU GRUB menu to choose 1 of 5 options, first one being just Ubuntu, I press enter while number 1 is highlighted, it appears to be loading something, then the screen goes blank (this is on my tv in living room). I do this same procedure on this laptop (the old crappy one) and it gives me the option to run live or install. I choose run live and it does fine.
 
I've created a flash drive with Windows 10 on it to access the repair tools, went into CMD and used bootrec /fixmbr , bootrec /fixboot , bootrec /rebuildbcd
That is not, how you can fix this.

You have deleted bootloader partition. To fix the damage, you have to recreate bootloader partition and recreate bootloader files on it.

Boot from Windows installation media into command prompt, execute following commands and show screenshot (upload to imgur.com and post link):
diskpart
list disk
select disk 0
list partition
list volume
 

ASK THE COMMUNITY