Question Mouse looses connection for a second.

Rit101

Prominent
Jul 30, 2020
18
1
515
0
When there is power fluctuation in my house, my UPS makes noise when adjusting the current supply and the exact same time of noise my mouse looses connection for a second, I don't know about other peripherals because it happens very fast but it hinders my work flow.
Now, I want to know what's causing this issue whether it's some hardware component or software?

My PC Specs -
UPS - Microtek Legend 1000 (1000VA ~ 800Watt)
PSU - Antec VP550P Plus
CPU - Ryzen 7 2700X
Ram - Crucuial Ballistix 8*2 GB at 3000MHz
GPU - Sapphire RX580 8GB
 

Lutfij

Titan
Moderator
That UPS does not and cannot support an 800W output from it. More along the lines of 400W~500W. How old is the PSU in your build? Make and model of your mouse? You might want to also check and see what BIOS version you're on at the time of writing. This will most certainly be your UPS playing tricks since the issue only crops up when your battery backup kicks in. FYI, the system shouldn't be powered by the UPS on battery backup. UPSes are designed to provide power for the system's end user in order to save your work and shut down the system.
 

Rit101

Prominent
Jul 30, 2020
18
1
515
0
That UPS does not and cannot support an 800W output from it. More along the lines of 400W~500W. How old is the PSU in your build? Make and model of your mouse? You might want to also check and see what BIOS version you're on at the time of writing. This will most certainly be your UPS playing tricks since the issue only crops up when your battery backup kicks in. FYI, the system shouldn't be powered by the UPS on battery backup. UPSes are designed to provide power for the system's end user in order to save your work and shut down the system.
Thanks for replying. Well my PSU was 8-9 months old. I just changed my psu to 650 watt lets see if my issue got solved or not!

Bro, I have one major issue in pc. Should I ask this here or create a new thread about it?
 

ASK THE COMMUNITY