Question My Gaming PC keeps Freezing when I do something.

jeremy0906

Prominent
May 8, 2018
23
0
520
3
So I been having a slight issue where I occasionally would have my pc freeze from time to time, like on startup my mouse courser would lag a freeze because something was running in the background, and every little thing in task manager would have “High Power Usage”. For almost anything actively running. I recently upgraded to a Ryzen 7 2700x with a Asus motherboard and new trident Z RGB RAM 16Gb 3200mhz. I thought it was maybe my OS so I did a complete fresh install, but when I start up I still notice the lag on the cursor. And when I open a program specifically epic games launcher, the entire Screen and PC just freeze. I have a feeling that I might have a bad PSU. Just wanted to ask the community before I make another investment on a part. My current specs are:
Ryzen 7-2700x/Trident-Z-3200mhz/Corsair RM850i/ Asus Strix X470-F gaming Mobo/ NZXT KRAKEN x72 Liquid cooler/ Asus GTX 1070
 

jonnyguru

Distinguished
Nov 30, 2006
914
257
19,440
45
A failing power supply would not cause these issues.

This is either a bad motherboard or bad RAM.

EDIT: Wait... it did this before and after replacing the motherboard, CPU and RAM?

Are only the graphics card and PSU the constants?
 
Last edited:

jeremy0906

Prominent
May 8, 2018
23
0
520
3
Update: just saw the temps for the CPU and it’s HOT with 85-104C degrees with liquid cooler and the wraith CPU cooler when installed on both. Not sure what to do now.
 

jeremy0906

Prominent
May 8, 2018
23
0
520
3
A failing power supply would not cause these issues.

This is either a bad motherboard or bad RAM.

EDIT: Wait... it did this before and after replacing the motherboard, CPU and RAM?

Are only the graphics card and PSU the constants?
Yes before I had a Asus board, and a intel core i5-6600k and would occasionally freeze and reset my PC. But with these new parts the PC freezes and I have to hard reset to turn it off.
 

jeremy0906

Prominent
May 8, 2018
23
0
520
3
Ok... Just saw your post about the CPU temperatures. That's REALLY hot. Something is wrong there.
I was using a program called “Speccy” to tell me the temp, but I decided to use “Ryzen Master” and the Temp there would tell me it was 35-40 degrees C. But the fans would still spin FAST when I even open a program. I tried using both my Liquid cooler and the Wraith Prism CPU cooler and the CPU is still hot. Trying to guess if it’s either the CPU or Mobo
 

ASK THE COMMUNITY

TRENDING THREADS