Question My monitor and keyboard doesn’t receive signal after upgrading my RAM

Mar 23, 2020
2
0
10
0
Watch the language
Hi, I thought about upgrading my RAM from 1x8 to 2x8, and since I didn’t know much about pc, I just put them in 1st and 2nd slots.
Also, while I was installing the RAMs I put them upside down, and I put a little bit of power....
Now, the pc turns on but no signal is received on my pc, and the keyboard that usually lights up instantly while booting doesn’t light up either. I replaced it the new RAM to the previous one and placed the same slot, but the result was same.

Then I thought maybe I can troubleshoot with beep sound if I boot up my pc without RAM, but still, no error sound, gpu, cpu, cooler fans are spinning and LED’s lighting up on my motherboard.

I checked on crucial memory finder that my new RAM was compatible with my motherboard, so I’m assuming that I Removed up my motherboard when I put 2 RAMs on first&second slot.

Can someone tell me what the potential issue is? Is there anyway I can fix it?

My motherboard: MSI Z270-A PRO
Previously installed RAM: BLS8G4D240FSB
 
Last edited by a moderator:
BLS8G4D240FSB is a Crucial Ballistix Sport LT 2400 MHz DDR4 DRAM Desktop Gaming Memory Single 8GB.

Memory modules sold as single modules have no guarantee to work in any configuration other than as a Single module.

Use of exact match, same thing, identical modules have no guarantee to be compatible together unless purchased together in a single kit.

Since you can make any combinations you want, you are free to play around and do your own compatibility testing with no guarantees.
 
Mar 23, 2020
2
0
10
0
BLS8G4D240FSB is a Crucial Ballistix Sport LT 2400 MHz DDR4 DRAM Desktop Gaming Memory Single 8GB.

Memory modules sold as single modules have no guarantee to work in any configuration other than as a Single module.

Use of exact match, same thing, identical modules have no guarantee to be compatible together unless purchased together in a single kit.

Since you can make any combinations you want, you are free to play around and do your own compatibility testing with no guarantees.

Sorry, I meant that I replaced new 2x8 with the BLS8G4D240FSB.
Btw the problem was solved.... please don't laugh but I was simply not giving enough pressure so that memory cards are properly installed.
 

ASK THE COMMUNITY