Question My PC crashes all the time... Can it be the CPU's PCIe controller?

Spyro 999

Prominent
Mar 17, 2020
77
2
535
0
Hello! (again)

On the next chapter of my cursed PC saga, I think I finally linked all the evidence in my head to one possible conclusion.

Sometimes, on boot, my motherboards lights (it's an MSI X570 tomahawk wifi) indicate a bad GPU and is stuck there until I shut it off and hopefully it works on the next try.
It also crashes around once every two days with WHEA UNCORRECTABLE ERROR in windows 10. Sometimes it even says there is no boot device detected on restart.
I also get randoms seemingly unrelated BSODs around once a week often pointing towards memory or the NVidia drivers.

Can it be my CPU who's playing on me?

I changed the motherboard and my ram (twice) and i tried Linux and another install of Windows. The crashes remains.

Should I ask for a warranty replacement for my Ryzen 5 2600 at AMD?

It looks like the errors are coming from components who are hooked up directly to the CPU and everything who goes by the chipset looks fine.

Thank you for your help.

Here's my build:

CPU: Ryzen 5 2600
GPU: ASUS TUF GTX 1650 Super
RAM: 2x16GB Corsair vengenace RGB 3200mHz
SSD: XPG sx8100 512GB SSD
Motherboard: MSI X570 tomahawk wifi
PSU: Thermaltake smart 500w
 

DSzymborski

Polypheme
Moderator
CPU failures are very unlikely.

What parts did you "swap" that you alluded to in your previous threads? One thread with detailed information is better than two threads with sparse information. Have you ever swapped out the GPU, hopefully powered by something with a PSU that isn't a junky group-regulated one like this one?
 

Spyro 999

Prominent
Mar 17, 2020
77
2
535
0
I swapped the GPU early on in my crashes but it did nothing. However the system is very different now than it was at the time and I do no more have that other GPU.

I do unfortunately don't have another reliable PSU to try. I have some old 500w stuff but it's from something like a 2008 prebuilt so I wouldn't trust it.

I used an HDD before to test the OS and storage and that changed nothing so I assume my SSD is ok.
 

ASK THE COMMUNITY

TRENDING THREADS