New built PC will not detect the hard drive

Apr 19, 2015
2
0
4,510
0
I just built a new PC.
Specs:
MSI Z170A M3
GTX 1070
Intel SSD M2 256GB
i7-6700k
and a WD Blue 1TB HDD

As I said before, when I first started up my PC, it detected my SSD so I installed W10 on it. However, in the bios settings and disk management, I cannot find my Hard drive anywhere. I tried using different power cables and I can feel the HDD spinning. I don't have any extra SATA cables but I used different SATA ports on the mobo but it only has two SATA ports (SATA 3 and 4 ports). I tried both and it still won't work. I tried exchanging for a new HDD and it still doesn't work. How can I make my PC detect it?
EDIT: I found my other SATA cable that came with the MSI mobo and I tried it and it still doesn't work.
 
Hey there, @Daniel Wigginbottom!

I'm sorry for the late reply and I'm sorry to hear about your detection issues with the WD Blue. :( I'd advise you to check how it will get recognized in another working PC. If it gets properly recognized by the other system, then it's not the issue.
If you don't have access to one, I'd suggest you try resetting BIOS just make sure you know how to re-configure your settings afterwards especially for the SSD (AHCI mode and boot priority).
If that doesn't help either, I'd strongly recommend going to your motherboard manufacturer's official website and manually update all the SATA controller & chipset drivers for your mobo. An outdated version (or a Windows version) of the drivers could easily cause such detection problems. While on it, check your BIOS version as well.
Please, share a screenshot of your Disk Management in Windows. It will really help me out.

Keep me posted! I hope I wasn't too late with my answer.
SuperSoph_WD
 

BrianP_195

Commendable
Jan 25, 2017
1
0
1,510
0
I know this was probably resolved LONG ago, but thought I would share this for someone else that might come across this post. I had the same problem. When installing Win7, it reports as if there is NO hard drive in it at all. It does not show up in the BIOS as well. After going through all the usual suspects (changing SATA cables, trying different ports, different hard drives etc.) None of that worked. Finally out of desperation, I moved the hard drive to the first SATA plug on my power supply lead and the other drives after....and everything worked. My power supply had all the SATA power plugs on one lead (the rest being the ol skool legacy plugs), the hard drive (or "boot" drive") HAD to be on the first SATA plug coming out of the power supply, the rest of the drives didn't matter. Maybe this is common knowledge, but no one mentioned it on several threads I'd read on this. Probably built a least 4 computers using SATA drives and never ran into this...
 

ASK THE COMMUNITY