Question New computer build boots then restarts every few seconds

Sep 6, 2020
2
0
10
0
New Pc build without an os powers on and displays bios but within a maximum of 30 seconds restarts (No components stop spinning) and sometimes gets as far as the bios.
This is a new build with no os as I can't get that far.
Build
Ryzen 5 3600x
XFX RX 580
2x8 Corsair vengeance
MSI b550m Pro vdh Wifi
500w thermaltake 80+
nzxt h510 with no extra fans (Two pre-installed)

Full explanation of problem
I finished installing pc and booted it up, in which upon first start up it got into bios. I could move around in the bios for a few seconds then a reboot occurs and then it boot loops. Sometimes in the looping it briefly makes it into the bios but often doesn't. Boot loop will continue for around 30ish minutes before loops stop and all debug lights are off and monitor displays black. The case and cpu fans will still spin though.
I have tried to: reset cmos, reseat both ram sticks and start pc with one stick at a time, reinstall all components into the case, test start without gpu to see what happens, reseating all power connectors
The only thing that booted differently was when I removed the gpu power and booted, upon boot while I didn't get a monitor signal (Not an apu) the pc didn't continue to loop. I know because my keyboard and mouse rgb continued to stay on, something that wouldn't happen when the pc would loop. My guess is that the gpu is bad, but I have no way to test the gpu as this is my only tower, all I have is a laptop otherwise.
 
Sep 6, 2020
2
0
10
0
Also when I can get the windows install media to appear for a moment there are lots of screen artifacts on the bottom quarter of the screen. It only appears on the one screen as when I get to the purple screen to choose language and region the artifacts disappear
 

ASK THE COMMUNITY