Question New Threadripper Build Boot Troubleshooting

May 20, 2019
1
0
10
Best answers
0
SUMMARY: A new home workstation here, I can't get it to post, and I've troubleshooted a fair bit and I'm thinking its either the CPU and the motherboard. What can I do to figure out my next steps?

First, here are the specs of the build, idea is its a small but punchy workstation that I can also dawdle on:

CPU: Threadripper 2950x
Cooler: Corsair H115i 280mm radiator​
Memory: 64 GB (4 x 16) Corsair Vengeance DDR4 3200 (RGB)
Mobo: ASRock X399M Taichi (Micro-ATX)
PSU: Silverstone Strider 800W 80+Titanium
GPU: EVGA Geforce RTX 2070 XC (with a view to upgrade when new amds arrive)
Storage: 2 x Intel 660p M.2 2280 2TB
Case: Corsair 280x

Obvs feedback on the build is welcome, but lets get to the business at hand: this fella isn't posting.
According to the mobo, it is factory installed with the 3.30 bios (compatible with the 2950x)
Note: Throughout all of this, the Dr. Debug display has remained blank, which is why I suspect the motherboard, but I'm pretty amateur so let me know what you think.


Confident in my pretty amateur skills, I went straight for building in the case after installing my case fans and CPU cooler. Get everything attached.
Test #1: Fully assembled.
plug in the psu (no power switch, which is silly, but it works)​
Mobo LED light beneath ASRock logo turns on purpleish, blinks blue semi rapidly, then slowly pulses blue. No sounds or Dr. Debug display.​
After mobo light starts pulsing blue (the steady state I assume), press case power button.​
Small click noise, light on CPU cooler flashes on for a fraction of a second. Everything else remains off.​
Nothing happens, continue waiting.​
Press power button on mobo.​
Nothing happens.​
Repeat this test a couple of times, resetting PSU between tests, waiting for all lights to go out and then waiting another 15 seconds.

Time to breadboard:
Test #2: Breadboard with CPU, GPU, various ram configurations, no cpu cooler
Plug in the psu​
Same light show as before, no sounds or dr debug​
nothing happens on pressing power button on mobo (no cooler to gauge half second reaction this time)​
Repeat with memory in various configurations. Same result.

Test #3: PSU paperclip test
The psu works, fan starts spinning quickly immediately (didn't do that for the previous two tests), then slows to a low spin and maintains that indefinitely.​
Test #4: Breadboard with no gpu or ram
Plug in psu​
Same light show, no sounds or dr debug (which it should with no ram)​
nothing happens on pressing mobo power button​
Test #5: Only mobo power, no power to cpu sockets, plugged cooler into mobo and psu
Plug in psu​
Same light show on mobo, no sounds or dr debug.​
press mobo power button​
case fan and cpu cooler both start and continue to work, rgb and all​
psu also starts spinning then maintains low rate​
still no dr debug​
Test #6: Same but this time with RAM to see if my ram slots are getting power (they are RGB as well)
Plug in PSU​
Same light show on mobo, no sounds or dr debug​
mobo power button​
case fan, cpu cooler both start and continue to work​
psu also starts spinning then maintains low rate​
ram rgb lights up​
no dr debug.​
Test #7: Same but with power to CPU sockets (8 pin and 4 pin, as specified by mobo instructions)
Plug in psu​
Same light show on mobo, no soudns or dr debug​
mobo power button​
nothing happens.​
Despite the mobo sticker claiming to be bios 3.30 (compatible with threadripper 2's), I decide to check and bios flashback to 3.50 anyway (ASRock can do that with only mobo power and no boot screen)
Fails out of bio flashback (solid green LED)
Try with 3.30
Fails our of bios flashback (solid green LED)
ETC continuing down the line.
Clear CMOS.
Try again no luck.
Test with CPU power still doesn't work.

What's next? Can I officially call it on behalf of one of these parts? Is there a key test I still need to do?

Thanks!
 

Lutfij

Titan
Moderator
Oct 7, 2009
28,052
205
123,740
Best answers
5,075
How long did you take the CMOS battery out of the battery socket? You might also want to see if a replacement PSU changes the issue.By replacement PSU, I meant borrowing one from your friend or neighbor, making sure you have the necessary connectors for connecting all leads on your components. You might also want to keep ASRock in the loop with the issue including the seller of the board in case you need to initiate an RMA.
 

ASK THE COMMUNITY

TRENDING THREADS