Mar 2, 2019
2
0
10
0
So I’m having the issue of no display detected on my new pc build
I’m using an Msi rc 580 armor (8gb)
Ryzen 5 2600
Asus prime b450m-a
Evga 600 bq PSU
Ballistix sport (8x2) ram
Viewsonic VX2276-SM-HD
I’m having trouble identifying the issue specifically, however when I plug into the HDMI on the graphics card I get no display
The computer turns on and all fans(including cpu fan) turn on and my keyboard lights up to indicate it is on.
My monitor is a view sonic model and the HDMI cable does work with my laptop connected to it.
The monitor supports VGA, hdmi and display port.
When I plug the monitor into the VGA on my motherboard, the monitor’s power button indicates it’s finding a signal, but then says no signal detected, which leads me to think that I have to plug into my graphics card for display however my graphics card only supports HDMI/DVI-d (going to try a dvi-VGA or dvi-hdmi cable after I can buy one after work) and the HDMI to graphics card doesn’t show the monitors power color change like it does for the motherboard when you plug the VGA into the motherboard.
I have not been able to see if bios starts when the PC boots because the no display signal and the case does not have a speaker so I can’t hear anything other than all the fans spinning.
All cables into the motherboard have been unplugged and plugged back in to ensure connectivity, and I’ve tried booting it with only 1 stick of ram(all slots tried)
I’ve tried reseating the CPU chip
All motherboard standoffs are fully secured.
I’ve unpluged and reinserted the graphics card into the motherboard


Long story short, need help with a no display signal detected issue.
Should HDMI work on initial start up of a new pc? Or does the computer need to install the drivers first? Again, I plan on trying a DVI to VGA or DVI to HDMI cable after work, but they can cost 30$ so I want to see if there’s any other solutions people know of. I have Spent about 950$ on all parts including monitor so desperate for a solution! Sorry for any formatting issues, I am typing on an iphone
 
Last edited:

vicvega1031

Prominent
Sep 27, 2017
17
0
510
0
I think you may just have a broken GPU or you didn't plug in your pcie power cables. I would try to see If you can get into the bios which is by pressing delete or f2. If you can not assess it then try unplugging your GPU and then plugging your monitor into your motherboard and try to see if you can get into the bios that way. If you cant get into the bios then my guess is the motherboard is broken.
 
Mar 3, 2019
1
0
10
0
Replying to add that I have a very similar situation. Graphic card in question is Gigabyte Radeon RX 570,
motherboard is Asus Prime B350M-A,
CPU is AMD Ryzen 5 1400.

In my case power is properly connected. I have accessed the BIOS and updated it, still no changes. The PC I'm using is functional, I'm posting this from that very machine, but using my old GeForce GT 730.

The only difference is that right now I have a monitor with only a VGA plug. I have bought an adapter since the 570 doesn't have VGA exit. First I thought the adapter might be the issue, but I had it changed (same model) and the issue persists.
 
Mar 2, 2019
2
0
10
0
[Solved] In my specific case, it was not using the DVI-D in the graphics card that was my problem.
It was using a DVI-D to HDMI adaptor (for my monitor) that ended up solving the problem. I don't think HDMI on the graphics card worked until I got windows booted up and the drivers were correctly installed.
So for anyone else having this same issue, I suggest making sure everything is completely plugged in correctly, and avoiding using the HDMI on the graphics card for first boot.
 

ASK THE COMMUNITY

TRENDING THREADS