No Network Adapters showing in Device Manager


Apr 27, 2011
Hello all,

maybe someone can help me with this strange issue:

i've just upgraded my graphic card and now i don't have any network adapters listed in the device manager (only firewire under +IEEE 1394 and all the other devices)

I've already reinstalled Windows 7 (64 Bit) and tried installing another LAN card (10/100) - that wasn't recognized.

Within the BIOS (award- Motherboard- GA-P35-DS4 ) i couldn't find anything related that should be turned off/on?

Could it be broken if it is not appearing there?
If yes- why isn't the motherboard recognizing my other LAN Adapter that i've installed on the bottom slot

Should i reset the Bios by pulling the battery/using the cmos jumper? What else could be the problem?

Thanks for any tips / help



Jan 4, 2011
Try this

Boot in safe mode
Remove NIC from device manager
Remove the NIC and any other cards you have
Reinstall NIC only! (use motherboard graphic card if you can, otherwise put it back in)
Install drivers

Second thing to try

goto Start > RUN > CMD > and type msconfig

Uncheck everything in startup and reboot and see if it works.

If it does work then the problem was a application running that was conflicting.

Have you had any bad storms or power outages lately? NIC's are easy targets for power surges..



Apr 27, 2011
first of all, thanks for your answer.

I've already resinstalled Windows - as i mentioned - no network adapters are listed in the device manager.
Its onboard and also not showing in the bios (was there before)
I've cleared CMOS using the jumper and pulling out the battery - nothing worked.

I think its dead (maybe i should try a BIOS update as last thing)
Now i'm using an wireless usb adapter to connect to my router.


Nov 22, 2014
FIXED - this is my story...

What I have:

Asus P5KPL motherboard with onboard LAN by Realtek
Windows 7
Virgin Media 5G superhub (but I use a wired connection from this to my PC)

What happened:

1) This morning the PC apparently switched off by itself, Windows did not shut-down.
2) When I rebooted, I had no internet connection, although access to the internet from other devices was fine.
3) No network adapters showed up in Control Panel, there was not even a section for Network Adapters.
4) I downloaded the latest Realtek network adapter drivers, but they couldn't find a network adapter so that didn't help.
5) The network cable was attached and I hadn't changed any software or hardware.

What I did:

1) Checked in the BIOS (with my motherboard is done by pressing 'DEL' on startup) that the onboard LAN was enabled - which it was, it hadn't changed.
2) Removed the CMOS battery (round battery on the motherboard which holds information for the motherboard when PC is switched off).
3) Went out for a few hours.
4) Replaced the battery and rebooted. I had to change the boot sequence in the BIOS to make sure that the hard drive with Windows on it was the first device that the BIOS looked for.
5) Waited for Windows to load - which then went off and found some new hardware (which must have been something connected to the motherboard - could have been anything)
6) Rubbed my eyes in disbelief as I had a working internet connection which I'm using right now to post this.

What I suspect happened:

Most likely - my PC experienced a power surge either from outside the house or inside which went through my router, down the network cable and into the LAN port on the motherboard. This then gave the motherboard a heart attack which disabled the network adapter, either accidentally or on purpose - if the motherboard is clever enough to disable misbehaving bits attached to it.

Less likely - I have heard that certain malware or viruses can mask the hardware so that it disappears from Windows, but the virus can still actually use it in the background. This way Windows doesn't think you have a network adapter so won't let you go online to fix the virus issue - clever.

I reckon that forcing the motherboard to reset its settings by removing the battery made it take a fresh look at what was connected to it, and this re-enabled the network adapter. It is also possible that if a virus was to blame - and the virus had changed the motherboard or network adapter settings to its own benefit then forcing the motherboard to use the default settings over-rode these nasty settings.

Either way, this worked for me.

If this doesn't work for you, then you could install a separate network card which are cheap, and avoid the onboard LAN completely, or even a wireless USB type of device.

Good luck all.


Apr 30, 2014

if the OP didnt find this helpful, id like to say it worked quite fine for my computer that wasnt detecting the onboard networking.

what i did:
- shut down windows and remove the bios battery for a few minutes and re-insert
- Boot into the bios and made sure the system boots from the windows HDD first thing (i also accidentally started a network boot, no idea what that is or if it helped)
-computer then booted into windows fine with networking access.

my thoughts for my situation is that the computer had power failure while in hibernation, or as this post said, could be a virus, as there was no virus program.