Question Out of Ideas...Need Some Help, Please

christiantambling

Commendable
May 2, 2018
3
0
1,510
0
About 2-3 weeks ago I had a rather unfortunate run in with an aftermarket fan controller I purchased that killed my motherboard. It was the Lamptron Fan Controller FC-8, I thought it had much better reviews than any I had seen so far, I did a little more digging and was confident that I had made a good purchase when I bought it. Install went smoothly, went to power on my PC after everything was installed (my 750 watt psu exceeded the recommended 600 per the instructions also), and the power led flashed, attempted to start and nothing. Tried it again, nothing. (Customer support was horrendous, wouldn't even consider helping me, took no fault for it).

Panicking, I unplugged the fan controller and attempted to start my computer without it. Nothing happened. Fearing for the worst I started testing each component. The EVGA psu came with a self tester, turned on fine. I also tested each pin to make sure the correct reading matched my psu voltage diagram. I assumed my once healthy GIGABYTE GA-990FXA-UD3 AM3+ was now dead. I went online and ordered the first board I could find, the ASRock 970M Pro3. Got it the next day, started attaching all my of my old hardware:

GIGABYTE AORUS Radeon RX 580 8GB
Team Vulcan 8GB DDR3 2400
Kingston HyperX FURY 8GB 1600MHz DDR3
AMD FX-8320
EVGA SuperNOVA 80+ PLATINUM 750W

This didn't do much either. The board would power on, all my be Quiet! case fans would spin, CPU fan would spin, too. My displays would continue to post "no input" and I was unable to load to BIOS/no post beeps could be detected either. I unplugged all necessary peripherals, bought a new stick of RAM (Patriot PSD38G16002H Signature 8GB DDR3) because I also thought at this point my RAM was fried, that did not help either.

Panicking again, I tried my old gpu (PowerColor Radeon R9 270 2GB) because I just replaced that several years ago, it never died on me so I knew if the gpu was fried, too then at least this could temporarily fix it/help me finish my troubleshooting.

I contacted ASRock, they were little to no help. Contacted Newegg and they just ended up having my return the board.

So here I was again, uncertain of what to do, and back to researching I went. I was able to locate and buy an older board, but after checking it was compatible with my cpu, I thought it was worth a shot. It was the Gigabyte GA-970A-UD3.

I am still having the same issue as I was with the ASRock board and I'm just very tired of thinking about what the issue could be is.

Takeaways:

No bios
No post
No display input detected
Power to the board/cpu fan/sys fans spin
PSU is still in good shape
New RAM did not help
Working video card did not help

The only thing I have not tested is the CPU, but could this prevent post or bios?? Or even displaying the boot sequence? I am just very tired and would appreciate some help. I know it's a bit of a mixed bag for older parts, but I've never had so much as an issue since I put it together several years ago. I don't want to have to upgrade to ryzen (just a bit costly for me right now) if I don't need to, but I am not sure where to go next.

Thanks,
Christian
 
That setup is pretty old by now and after all the effort you have put into troubleshooting, further diagnostics may cost you money as you may need to test with substitutes at this point. Are you sure its worth the effort???
An easier thing to do is to go to a nearby computer store and let them diagnose the issue, as unlike you they usually have spares handy at their disposal. It can save you a lot of time and money.
Anyways, if you wanna do it nevertheless, heres where you start...
Also, a detailed part list will be helpful, including your storage drives.
 

ASK THE COMMUNITY

TRENDING THREADS