Question PC booted into BIOS once, now won't launch into BIOS or Windows 10 installer.

dkottkamp

Reputable
May 22, 2019
25
0
4,530
0
Hi, I was helping my friend build his PC over a discord call, and everything went pretty smoothly. However, if the PC is moved or the back panel is put on it won't boot, I expect it is a loose cable, but as I am not there to check I can't be sure. he hasn't checked yet and we want to figure out what the software issues are before I ask him to go through and recheck every cable. we expected to have to do a bios flashback but we somehow booted into bios. On the first launch, the bios prompt popped up and he wasn't fast enough to tell me, the Asus logo went away and then the screen stayed black. We tried turning the PC off with the power button but unfortunately, that didn't work, so he was forced to flip the switch on the back of the PSU. He turned the PC back on and spammed delete like usual this time. We got into the bios, and as I was refreshing myself on how to put ram up to speed, and all the other various things you have to do in bios when you boot the PC for the first time (I had trouble remembering as I hadn't done anything with PC's since covid hit). As I was refreshing myself the screen went black. This time we had a windows installation drive installed and it never prompted us. He just tried booting it again, and the screen remained black this time. Any help would be greatly appreciated. We think it may just need a bios flashback but we aren't sure as it booted into BIOS once.

Here is the PC parts picker list: https://pcpartpicker.com/list/jd2p3y
PC Builder - AMD Ryzen 5 5600X, GeForce RTX 3070 Ti, Cooler Master ...
 
Hi, I was helping my friend build his PC over a discord call, and everything went pretty smoothly. However, if the PC is moved or the back panel is put on it won't boot, I expect it is a loose cable, but as I am not there to check I can't be sure. he hasn't checked yet and we want to figure out what the software issues are before I ask him to go through and recheck every cable. we expected to have to do a bios flashback but we somehow booted into bios. On the first launch, the bios prompt popped up and he wasn't fast enough to tell me, the Asus logo went away and then the screen stayed black. We tried turning the PC off with the power button but unfortunately, that didn't work, so he was forced to flip the switch on the back of the PSU. He turned the PC back on and spammed delete like usual this time. We got into the bios, and as I was refreshing myself on how to put ram up to speed, and all the other various things you have to do in bios when you boot the PC for the first time (I had trouble remembering as I hadn't done anything with PC's since covid hit). As I was refreshing myself the screen went black. This time we had a windows installation drive installed and it never prompted us. He just tried booting it again, and the screen remained black this time. Any help would be greatly appreciated. We think it may just need a bios flashback but we aren't sure as it booted into BIOS once.

Here is the PC parts picker list: https://pcpartpicker.com/list/jd2p3y
PC Builder - AMD Ryzen 5 5600X, GeForce RTX 3070 Ti, Cooler Master ...
You need to verify everything is securely plugged in the bios is way to touchy to update with unstable power. If there is a power failure in the middle of it the system is bricked for life
 

ASK THE COMMUNITY