Question PC won't boot without removing the DisplayPort Cable and then plugging it back in after POST ?

Nov 21, 2021
2
0
10
0
Hi, the title states the issue. I know this has been asked and answered before but both the accepted solution and authors replied solution doesn't apply to me, link at bottom...
To start, this only became an issue one day when I tried to reboot while my GTX 770 was installed with my current setup (Below).
Originally, according to my POST buzzer on the mobo it was a graphics card issue, I thought my 8yo graphics card died, so I replaced it with my current graphics card(GTX1080, tested personally before purchasing from a friend, so I knew it 100% worked)
But the same problem persisted. So I started troubleshooting, taking out my old desktop. Steps below.

Hardware info:
3600XT
GTX 1080 (Asus Strix)
RM600x
Asus Prime B550m
Primary Monitor; 4k LG usually connected by DisplayPort
Secondary Monitor; 1k LG, HDMI
I'm sure the rest is irrelevant.

Troubleshooting:

  • I've made a couple of switches of each compatible part between another intel 3570k pc with a working compatible motherboard.
  • Neither 1080 nor 770 would boot with DisplayPort installed, (I only went according to post at this stage, so I never figured it was a DisplayPort problem)
  • Swapped both 1080 and 770 into old 3570k pc and both booted with either DisplayPort or HDMI, inputted to either of my 4k or 1k LG monitors ---(So the DisplayPort/4k monitor you'd assume was not the problem. You'd therefore assume it was the motherboard...)
  • I Purchased a new motherboard of the exact same make and model, b550m Same issue, this time I figured out it only booted while DisplayPort was plugged in, and I swapped MB back to check. ---(I was then pretty stumped, maybe power supply to the new board, no. swapped it out for my old working corsair 500w PSU and the issue persisted)
  • For irrational fun, I also swapped out the 3600XT with a working 3600 my housemate's pc had, the ram with the sticks from his PC, still nothing. ---(Then after googling and all that, I turn to you)
Summation:

  • Everything worked until one day I rebooted, I changed nothing including not changing any software or display settings.
  • I tried 2 graphics cards, 2PSUs s, 2 processors, 2 motherboards, 2 monitors using configurations;
  • HDMI & HDMI (Worked) - HDMI & DP (Not Working) - DP & HDMI (Not) -DP 4k (Not) -DP 1K (Not) -HDMI on either 1K and 4k Monitors only (Worked).
  • On the old PC, It boots fine with a DP connected with both graphics cards in any configuration.
  • On the new setup it suddenly doesn't, regardless of swapping out every conceivable part.
This is a real head-scratcher...
-On the bright side, the PC still boots fine if I disconnect the DP first from the monitor, wait for the POST beep, then plug it in. But it's really bugging me that I have to do it...

Seriously any help or insight would be greatly appreciated
& I hope I answered all of your possible troubleshooting follow-up questions to really narrow down the wide range of possible problems to the problem at hand.
-I cant return either graphic card to the manufacture, but I assure you they both work perfectly on my old Intel and the previous owner's pc in the case of my new(er) 1080.
-Both graphics cards can run the furmark 4k benchmark for the 1080 and 2k for the 770 for as long as you want to be installed in either PC, DP installed or not, with no issues & no software or PC crashes.

Similar issue, though not relevant.
 
Dec 17, 2021
2
0
10
0
Nightcrawlers, did you ever figure anything out on this issue. It sounds just like what happen to me yesterday. everything has been fine for a year and after a reboot last night I have to power the system off , pull the DP cable, power on, wait for it to get past the boot light, plug cable in, Bios is in the screen, tell bios to move on and then it will boot into Windows.

Thanks
Kevin
 

tecmo34

Administrator
Moderator
There was a known issue with the older Nvidia (and some newer 3000 Series Cards) with DisplayPort. Nvidia put a a firmware fix a while back for the older cards, which the info. is below. It wasn't 100% of the time but happened.


This could be the issue, as I had the same issue with my RTX 3080 Ti not boot properly with a DisplayPort cable until a firmware update came out and fixed the issue. Funny part, it work just fine in my son's system but didn't work in my system properly till after the firmware update in mine.
 
Last edited:
Reactions: Metal Messiah.
Nov 21, 2021
2
0
10
0
Unfortunately, the tool does not support either my 1080 or my 780, but I really thank you for the most likely source of the problem. It absolutely must be an Nvidia firmware update that caused it. As with all of my troubleshooting, swapping parts and cables, for the life of me I could not figure it out.
Of f***ing course, Nvidia would not support older devices with its fix. But to be honest, since my post, it's become second nature to reach to the back and unplug the cable, wait for the right bios beep code from the motherboard, then plug it back in.

For all those who find this in a google search,
try downloading the tool featured in this link: https://www.tomshardware.com/news/nvidia-displayid-firmware-update

And for those like me, I'd recommend buying a bios beeper/speaker and just unplug the DP wait for the code plus 5 seconds, and plug it back in.
It's not a proper solution, but until Nvidia fixes this issue for older graphics cards, it's the best solution I have.

But if anyone has found a real solution I'd really appreciate your help.
 

ASK THE COMMUNITY