Question PCI-to-PCI Wakeup w/ Ryzen 5600X and B450 MSI Tomahawk Max II

Feb 1, 2022
5
0
10
0
I upgraded the CPU in my system from a Ryzen1600 to a Ryzen 5600X. I had to re-flash the BIOS to the 5600X version to get it going. After re-flashing, everything works fine except for Wakeup. I cannot get the system to wake up using the keyboard or mouse. System only wakes with the PC button. Wakeup worked perfectly with keyboard or mouse on the 1600 before changing the CPU (and BIOS). The problem seems to be that I cannot set the "Resume By USB Device" option to "enabled" in the BIOS, because setting it to "enabled" causes the computer to instantly wake up after being put in Sleep Mode. The specific event triggering the wakeup is "Wake Source: Device -PCI-to-PCI Bridge." Also, the network adapter has been disabled from allowing to Wake in Device Manager. Any ideas? Can I turn off whatever is causing this? Thank you.

Motherboard: B450 Tomahawk Max II
BIOS (the latest non-Beta): 7C02vH5 2021-05-17 or EC702AMS.H50
Chipset driver (the latest): 3.10.22.706 2021-11-02
Windows 10 Pro
Version 21H1
OS Build 19043.1466
Experience: Experience Pack 120.2212.3920.0

BIOS Wakeup Settings (at current time):
Wake Up event: BIOS
RTC Alarm: Disabled
PCI-E Device: Disabled (enabling it causes instant Wakeup triggered by "Device -PCI-to-PCI Bridge")
Resume by USB Device: Disabled (enabling it causes instant Wakeup triggered by "Device -PCI-to-PCI Bridge")
Mouse: Enabled
Keyboard: Any Key
 
Last edited:
Feb 1, 2022
5
0
10
0
Hey there,

Did you clear CMOS after you updated the bios? If not this may solve your problem. Check your mobo manual for instructions on how to do it.

Let us know how you get on.
Thank you for the answer. I cleared it. It did not change the behavior. Let me ask you this: Am I correct in assuming that the option "Resume by USB Device" must be enabled in the BIOS to enable Wakeup along with enabling Wakeup by mouse and/or keyboard?
 
Feb 1, 2022
5
0
10
0
Thank you. Yes, I toggled it on and off. When it's toggled on, I get the symptom of instant Wakeup immediately after shutdown which is caused by the PCI-to-PCI Bridge trigger. Therefore, I really can't leave it turned on. That's what I think the problem is. If I can't turn it on, then I am essentially turning the Wake functions off.
 
Feb 1, 2022
5
0
10
0
Have you tried switching power profiles? Try high performance or balanced and see if that helps.
Thank you. I have tried every combination I can think of concerning power profiles. I still get the immediate restart which seems to be caused by the PCI-to-PCI Bridge trigger when "Resume by USB Device" is enabled. When "Resume by USB device is disabled, there is no wakee-uppee.
 
Feb 1, 2022
5
0
10
0
Looking at the Wakeup event that is causing trouble, I see that it is this:

C:\Windows\System32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
Wake Source Count - 1
Wake Source [0]
Type: Device
Instance Path: PCI\VEN_1022&DEV_1483&SUBSYS_12341022&REV_00\3&11583659&1&0B
Friendly Name:
Description: PCI-to-PCI Bridge
Manufacturer: (Standard system devices)
Does anyone know what PCI\VEN_1022&DEV_1483&SUBSYS_12341022&REV_00\3&11583659&1&0B is?

Thanks.
 

ASK THE COMMUNITY