Question Peculiar display problem.

DondoFX

Commendable
Apr 13, 2017
21
0
1,520
3
Hi,

I got a new Samsung 28" 4k Monitor, the cheapest one out there with 10bit color depth. not for gaming but for media production or other hobbies. I play all my games in FHD or 1440p. BUT, if I use 4K in games, or do an alt tab while in game or anything that uses 3D, it starts turning off and on. The interval between the turn-off-and-ons depends on what resolution I'm playing, better said, if it's more GPU intensive the cycles are more often, like every 2-3 seconds. I'm guessing that for this one is the display, because the other display [some Acer with 1280 x 1024] doesn't turn off. I'm trying to understand this too, why if it's more GPU intensive the monitor turns off? I have a RX 480 4 GB from XFX, to be clear.


CPU: Ryzen 2600, AMD
RAM: Corsair Vengeance LPX 16Go (2x8Go) DDR4 2400MHz C16 XMP 2.0 Kit
MOBO: Gigabyte GA-B450M-DS3H
PSU: Seasonic S12II-620 80 Bronze
GPU: XFX RX 480 RS 4GB
Monitors: Samsung U28E590D and Acer V193W.

It's a big challenge for me, if there's someone that has met this problem and succeeded in resolving it, please tell me. I would love to hear from you!
 
Last edited:

hang-the-9

Titan
Moderator
Hi,

I got a new Samsung 28" 4k Monitor, the cheapest one out there with 10bit color depth. not for gaming but for media production or other hobbies. I play all my games in FHD or 1440p. BUT, if I use 4K in games, or do an alt tab while in game or anything that uses 3D, it starts turning off and on. The interval between the turn-off-and-ons depends on what resolution I'm playing, better said, if it's more GPU intensive the cycles are more often, like every 2-3 seconds. I'm guessing that for this one is the display, because the other display [some Acer with 1280 x 1024] doesn't turn off. I'm trying to understand this too, why if it's more GPU intensive the monitor turns off? I have a RX 480 4 GB from XFX, to be clear.


CPU: Ryzen 2600, AMD
RAM: Corsair Vengeance LPX 16Go (2x8Go) DDR4 2400MHz C16 XMP 2.0 Kit
MOBO: Gigabyte GA-B450M-DS3H
PSU: Seasonic S12II-620 80 Bronze
GPU: XFX RX 480 RS 4GB
Monitors: Samsung U28E590D and Acer V193W.

It's a big challenge for me, if there's someone that has met this problem and succeeded in resolving it, please tell me. I would love to hear from you!
I would check the video card first. What type of connection are you using? Is there another one you can try? Or test the monitor with another system that can run 4k?
 

DondoFX

Commendable
Apr 13, 2017
21
0
1,520
3
I quite don't have those options like another [same] one or test it with another system. Just moved to another country and the assholes that I call friends here are not that tech savvy. But to answer the first two questions, the video card is good, I tried with other make monitor, more like a TV and it worked all the time, no problems. I'm guessing it's some capacitors going crazy, but I was wondering if someone had the same problem and fixed it, so I can go directly to the problem and not go into the monitor in search of Nemo. ^_^ Thanks for the reply! I've succeded lowering the time between the turn-offs and even the monitor settings. I go 2k with no problem on DisplayPort 1.1, but as soon as I go DP 1.2 and I turn FreeSync it goes party mode. Well, i'm guessing no more returns from amazon for me.
 

ASK THE COMMUNITY

TRENDING THREADS