• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Qualcomm Wireless Network Adapter Automatically Disabling/Crashing/Turning OFF only while playing games.

Jul 2, 2020
6
0
10
0
Hello there,

So now i am totally fed up with this problem that i am facing since the start of the June 2020 and after updating my system to latest Windows 10 version 2004. My laptop is ACER ASPIRE VX 15 running latest build of Windows 10 Home Build 19041.331 Version 2004. My wireless network adapter is Qualcomm Atheros QCA61x4A. Since the start of the June 2020 my network adapter is continuously getting disabled or stopped only when i am playing games. Things i tried:

1. Resetting my drivers to factory version or installing the version provided on my OEM website.

2. Updating the driver version to the latest one.

3. Turning off the power management feature of the Wireless Adapter from Device Manager .

4. I have also RESET my Windows 10 and clean install the windows. When i did this everything worked totally fine for about 10-12 days but now since yesterday the problem is back and i haven't made any changes to the system in this time.

5. Scanning Windows for any corrupt files.

6. Resetting the network settings.


I haven't tried going back to Windows 10 version 1909 though. Also when i searched this issue on the internet i found 2-3 more people who are facing same issue with the Qualcomm Atheros QCA61x4A. Few are using ACER laptops and one other person was on Windows 10 v1909 and still facing the issue. He even tried going back to 2018 version of WIndows 10 and still facing this issue.

The weird thing about this issue is it only happens when i am playing some game. Otherwise when i am simply browsing the internet or downloading some file Wi-Fi works totally fine without any interruption. Other thing is when i uninstall the driver and Windows install the required driver again then for that period everything works fine till the next reboot.


I am attaching the Windows Log/Event Viewer Screenshot when this error arises.

Also i wanna mention that in past 2 days i have faced 2 types of BSOD just after my Wireless Adapter got crashed or stopped.

Error name:

1. IQRL_NOT_LESS_OR_EQUAL

2. WFP INVALID OPERATION (i have memory dump file for this BSOD)

Both BSOD happened when i was in between of the game. Both BSOD happened on two different consecutive days.
 
Last edited:
Jul 2, 2020
6
0
10
0
Is it possible to install wireless network adapter driver of some other Wireless Card manufacturer ? My wireless card is Qualcomm Atheros QCA61x4A and those driver are of Killer's Wireless AC1550/AX1650 .

Moreover this seems some compatibility issue of Qualcomm driver with the Windows 10 version 2004. As similar issue has already happened once when November 2019 update was released. Microsoft had blocked the update for some devices using Qualcomm Wi-Fi- card at that time and afterwards released new version of Qualcomm Wi-Fi affected cards. Here is the link of that issue: https://support.microsoft.com/en-in/help/4531941/updating-to-a-new-version-of-windows-10-on-devices-with-some-driver-ve
 
Last edited:

Colif

Win 10 Master
Moderator
Qualcomm originally created Killer WIFI and a few years later, the 2nd was spun off as its own company and in recent months has been bought by Intel... so Killer made the software for Qualcomm units and I often suggest them for Atheros units.

usually its easier to know if the drivers will work
Qualcomm don't normally make their own drivers, you get them from the oem who makes the unit. Many of those use KIller themselves. https://www.qualcomm.com/products/qca6174a
Wi-Fi Standards: 802.11ac Wave 2, 802.11a/b/g, 802.11n

I am not sure if the drivers would work in your case, difficult to tell if they are the same or not - https://www.killernetworking.com/products/killer-wireless-ac-1550/#1538447818646-1315ea8c-4267

But you might be right, it might be WIn 10 2004
 
Jul 4, 2020
4
0
10
0
Hello there,

So now i am totally fed up with this problem that i am facing since the start of the June 2020 and after updating my system to latest Windows 10 version 2004. My laptop is ACER ASPIRE VX 15 running latest build of Windows 10 Home Build 19041.331 Version 2004. My wireless network adapter is Qualcomm Atheros QCA61x4A. Since the start of the June 2020 my network adapter is continuously getting disabled or stopped only when i am playing games. Things i tried:

1. Resetting my drivers to factory version or installing the version provided on my OEM website.

2. Updating the driver version to the latest one.

3. Turning off the power management feature of the Wireless Adapter from Device Manager .

4. I have also RESET my Windows 10 and clean install the windows. When i did this everything worked totally fine for about 10-12 days but now since yesterday the problem is back and i haven't made any changes to the system in this time.

5. Scanning Windows for any corrupt files.

6. Resetting the network settings.


I haven't tried going back to Windows 10 version 1909 though. Also when i searched this issue on the internet i found 2-3 more people who are facing same issue with the Qualcomm Atheros QCA61x4A. Few are using ACER laptops and one other person was on Windows 10 v1909 and still facing the issue. He even tried going back to 2018 version of WIndows 10 and still facing this issue.

The weird thing about this issue is it only happens when i am playing some game. Otherwise when i am simply browsing the internet or downloading some file Wi-Fi works totally fine without any interruption. Other thing is when i uninstall the driver and Windows install the required driver again then for that period everything works fine till the next reboot.


I am attaching the Windows Log/Event Viewer Screenshot when this error arises.

Also i wanna mention that in past 2 days i have faced 2 types of BSOD just after my Wireless Adapter got crashed or stopped.

Error name:

1. IQRL_NOT_LESS_OR_EQUAL

2. WFP INVALID OPERATION (i have memory dump file for this BSOD)

Both BSOD happened when i was in between of the game. Both BSOD happened on two different consecutive days.
Oh my man!! I am facing the exact same issue. My laptop is Acer Swift 3 of the same windows build and the same wireless adapter Qualcomm Atheros QCA61x4A. Unlike you though mine stops working randomly while i am surfing or watching youtube or something, like out of nowhere.If I am playing games, it is completely fine.

Whenever it stops working like that I just either
  1. Delete the driver, scan and reinstall it.
  2. There were some console commands i found in Yt i just copy pasted.
After doing any of them though, it seems completely fine for some time but the same thing happens again and again. I am really tired of this. Someone really help out!!

I have updated the driver, Resetted the network and what not. Just someone help us out!
 
Jul 2, 2020
6
0
10
0
Oh my man!! I am facing the exact same issue. My laptop is Acer Swift 3 of the same windows build and the same wireless adapter Qualcomm Atheros QCA61x4A. Unlike you though mine stops working randomly while i am surfing or watching youtube or something, like out of nowhere.If I am playing games, it is completely fine.

Whenever it stops working like that I just either
  1. Delete the driver, scan and reinstall it.
  2. There were some console commands i found in Yt i just copy pasted.
After doing any of them though, it seems completely fine for some time but the same thing happens again and again. I am really tired of this. Someone really help out!!

I have updated the driver, Resetted the network and what not. Just someone help us out!
Yeah man you aren't alone. There are multiple people who are facing this issue with Qualcomm Atheros QCA9377 and Qualcomm Atheros QCA61x4A wireless adapter. May i know what Version of Windows 10 you are on. What is the Build Number of your Windows 10 ? I am assuming that this is happening after latest Windows 10 version 2004 update because before that everything was fine for me at least. It seems like incompatibility of the network adapter driver with latest update of Windows 10.

Lets hope Microsoft addresses this issue as soon as possible.
 
Jul 4, 2020
4
0
10
0
Yeah man you aren't alone. There are multiple people who are facing this issue with Qualcomm Atheros QCA9377 and Qualcomm Atheros QCA61x4A wireless adapter. May i know what Version of Windows 10 you are on. What is the Build Number of your Windows 10 ? I am assuming that this is happening after latest Windows 10 version 2004 update because before that everything was fine for me at least. It seems like incompatibility of the network adapter driver with latest update of Windows 10.

Lets hope Microsoft addresses this issue as soon as possible.
It's really annoying man, Did you find any solutions?
Mine is Windows 10 Home Build 18362.900 Version 1903. It's not even the 2004 build. And this has been happening since June 1 if i remember correctly. I think there was some windows update or sort of.

Let us know if you find any solution as soon as possible man!!
 
Jul 2, 2020
6
0
10
0
It's really annoying man, Did you find any solutions?
Mine is Windows 10 Home Build 18362.900 Version 1903. It's not even the 2004 build. And this has been happening since June 1 if i remember correctly. I think there was some windows update or sort of.

Let us know if you find any solution as soon as possible man!!
Same here, for me also it is happening since the First week of June. And at that time Microsoft released some updates for all the versions of Windows 10. It could be the buggy update of Windows that might be causing this problem.
Till now i have tried so many things and searched several forums but didn't got any exact solution.
I am still trying to solve this problem. Will try more things. If i get any positive result i will be letting you know here.
 
Jul 4, 2020
4
0
10
0
Same here, for me also it is happening since the First week of June. And at that time Microsoft released some updates for all the versions of Windows 10. It could be the buggy update of Windows that might be causing this problem.
Till now i have tried so many things and searched several forums but didn't got any exact solution.
I am still trying to solve this problem. Will try more things. If i get any positive result i will be letting you know here.
Did you find any solution bud?
 
Jul 2, 2020
6
0
10
0
Did you find any solution bud?
No man, still facing the problem to this date. Waiting for the Qualcomm Network Adapter Update. Last update of the driver is of April 22, 2020. Maybe latest update of the driver could solve the issue. Also if you find any solution do let me know over here.
 
Jul 4, 2020
4
0
10
0
No man, still facing the problem to this date. Waiting for the Qualcomm Network Adapter Update. Last update of the driver is of April 22, 2020. Maybe latest update of the driver could solve the issue. Also if you find any solution do let me know over here.
So, like some 4 days ago, I got a windows patch update ( > 2GB) and now the driver seems to be working pretty fine and got troubleshooted automatically. Though occasionally the usual thing happened but for the last 48 hrs, I haven''t encountered the problem! Any update from your side? (Mine is still version 1903, though I did get the 2004 one, I am not planning to install it for now)
 
Jul 2, 2020
6
0
10
0
So, like some 4 days ago, I got a windows patch update ( > 2GB) and now the driver seems to be working pretty fine and got troubleshooted automatically. Though occasionally the usual thing happened but for the last 48 hrs, I haven''t encountered the problem! Any update from your side? (Mine is still version 1903, though I did get the 2004 one, I am not planning to install it for now)
Same here, its been more than a week for me and I haven't encountered the problem. Only it was yesterday when it happened again after so many days but it happened only for once. Usually the problem occurs again and again. So i think it is kind of getting solved on its own. Probably due to windows update. Also I'm waiting for the latest version of driver, that may solve this issue completely. Installed version is 12.0.0.948 for me which is from April 2020. So lets wait more.
 

ASK THE COMMUNITY