R9 280x Driver Problems, need urgent help!

IronicRainbow

Honorable
Nov 27, 2013
7
0
10,510
0
Hello. I recently purchased an MSI R9 280x Twin Frozr II. It was about $300, and it just arrived today. I slapped it in my system and *tried to install the drivers from both the disc and the website. However, when I tried this it says: "Completed (errors have occoured)" or something along those lines. I opened up the log and it showed that both the video driver and the HDMI audio driver did not install, however, everything else did. I tried this with the 13.11 and 13.10 drivers. Does anyone know why this happens?

P.S. My power supply is 600w, so it is suitable.
 

thismafiaguy

Distinguished
Jan 9, 2011
612
0
19,160
80
Use driver sweeper to completely uninstall all Radeon drivers, then re-download the latest drivers and try the installation again. I've actually seen quite a few people with Radeon driver issues. In most cases this problem is solved by a clean re-installation.
 

IronicRainbow

Honorable
Nov 27, 2013
7
0
10,510
0


You mean the option to uninstall the drivers when you open up the Catalyst install? Yes, I have. That too was unsuccessful.
 

IronicRainbow

Honorable
Nov 27, 2013
7
0
10,510
0
UPDATE: I noticed my card was on the '2' BIOS switch setting. I flipped it to '1', started up my PC, and NONE of my peripherals turned on, including monitor, mouse, or keyboard.
 

IronicRainbow

Honorable
Nov 27, 2013
7
0
10,510
0
Also it is worth noting that when I go into Device Manager I cannot see anything, it just gives me a white space. This was not apparent before my GPU upgrade.
 

Similar threads


ASK THE COMMUNITY