Question Random colored lines + brief black screen ?

Aug 30, 2021
6
0
10
0
Hello everyone.
I bought my 1050 Ti (low profile version) about 6 months ago and every once in a while I experience random colored lines that appear on the screen for like 0.1 seconds followed by a brief black screen (sometimes just the black screen). This happens very randomly: when browsing on the internet, when gaming, editing, etc. but there can be days (even weeks) when this doesn't happen at all. I can "force" this to happen through quickly switching to different programs, but it's still very random.
I recently tried this on two different monitors with 2 HDMI cables and a DisplayPort with same results. I also tried changing the "power management mode" option on Nvidia Control Panel from "Optimal power/adaptive" to "Prefer maximum performance" and it seems to fix the problem, however, I know this is not a good idea.
I know I have been dragging this for too long, but I need to know. Can this be a PSU problem? HDD? Or I just have a faulty GPU?

My specs:

CPU - AMD Ryzen 5 3600 w/Stock Cooler
Motherboard - MSI B550M PRO-VDH WIFI
RAM - (4x4) G.Skill DDR4 2400MHz Value RAM
GPU - Gigabyte GTX 1050 Ti OC Low Profile 4GB
PSU - Deepcool 500W DA500 80Plus Bronze
HDD - Toshiba DT01ACA100 1TB
Monitor - Gear 21,5'' M2298G 60Hz
 
Do all the refresh rates match in Nvidia control panel, windows display settings, and monitor? Also check windows display, graphics settings(at bottom of page) enable hardware accelerating and variable refresh rate, see if this helps at all.
 
Aug 30, 2021
6
0
10
0
Do all the refresh rates match in Nvidia control panel, windows display settings, and monitor? Also check windows display, graphics settings(at bottom of page) enable hardware accelerating and variable refresh rate, see if this helps at all.
I double checked and it's all good. I'll try enabling that option and see how it goes. Also good to know that max. performance is not that big of a deal, I'll try that too if hardware acceleration doesn't work. Thanks! :)
 
Aug 30, 2021
6
0
10
0
Turning on "Hardware Accelerated GPU Scheduling" on the Windows settings didn't work. I guess I have to go with the max. performance option, which is a bummer as it really doesn't have to be the only solution to this annoying problem. Anyways, if you have any other idea to what the problem might be, I'll check it out.
 
Aug 30, 2021
6
0
10
0
It is weird that prefer maximum performance is the only thing thats works. It is to prevent the gpu from reducing power when it isn't called for. Something in the drivers then perhaps. What did you have installed before the 1050?
I had a different build with an old AMD APU, no dedicated GPU. The only thing I used from my old PC was the HDD, and I made sure I deleted the AMD drivers with DDU before installing the 1050 ti.
Here are my Nvidia settings: https://prnt.sc/1r54e5a https://prnt.sc/1r54hij https://prnt.sc/1r54jeh
 
Aug 30, 2021
6
0
10
0
The only thing I would say to change in settings is Vertical sync from use 3d settings to off. And of course turn your power back to prefer maxium performance. What driver version are you using?
I'm using the latest drivers, 471.96, as going back to older versions doesn't fix the problem. I'll change that setting then and stick to max. performance. Thanks again. :)
 

ASK THE COMMUNITY

TRENDING THREADS