Question Rx 5700 xt no post

Azaell

Prominent
Nov 13, 2019
6
0
510
0
I bought a powercolor rx 5700 xt red devil last year,it worked fine, although I had some driver issues with some games but nothing serious.

Today I was using the pc with no issues and suddenly it died, no post, everything is on, even the card fans and leds, but there's no video signal, not even the bios, tried changing the graphics card and everything else seemed to work fine so I suppose my 5700xt is the issue, is there anything I can do? It's been more than a year since I bought it so I guess it has no warranty left... I hope this isn't the end of a 450$ graphics card

I tried the graphics card on another pc, and still no post.
 
I bought a powercolor rx 5700 xt red devil last year,it worked fine, although I had some driver issues with some games but nothing serious.

Today I was using the pc with no issues and suddenly it died, no post, everything is on, even the card fans and leds, but there's no video signal, not even the bios, tried changing the graphics card and everything else seemed to work fine so I suppose my 5700xt is the issue, is there anything I can do? It's been more than a year since I bought it so I guess it has no warranty left... I hope this isn't the end of a 450$ graphics card

I tried the graphics card on another pc, and still no post.
This should be a dual bios card look closely along the edge of the card for a switch and flip it the bios may have crashed and you may need to re flash you first bios
 
Reactions: Azaell

Azaell

Prominent
Nov 13, 2019
6
0
510
0
It has a switch that says:
BIOS
OC/SILENT
I flipped it and the mb bios started, but after a few seconds it flickered and... black screen again, and now it does nothing regardless of the position of the switch
 
The other pc has a cougar gx 800w, so I don't think there's much difference there
Okay thats a little odd the likely hood of both of the psu's being the issue are low the cougar is a lot better quality then the one you are using i can see yours being a problem not the cugar really though... Try the other system in second bios. It may post this way however if it wont the gpu has faild and i would recommend seeing if it is worth sending in for refurbishing the price of gpu's today it can be worth having it repaired by the right people
 

ASK THE COMMUNITY