[SOLVED] rx 590 undervolt resetting

Jul 23, 2016
61
0
4,530
0
I bought my rx 590 (xfx fatboy) in december 2019, and it was running hot 80°C at 60% fan speed(about 2300rpm), so i decided to undervolt and since then i've been gaming at 1075mV and the temps wont go above 70°C they hang around 66-68. I've been trying to play rainbow six siege using vulkan but it seems to have more impact on temperature than dx11 (temps go to 77°c) so i thought maybe it was because of the summer ambient room temperature and decided to stay on dx11 since the game also crashes on vulkan. today i installed metro exodus and i've been trying to play it but suddenly the temps go crazy and i notice that the gpu is using volts as when i got it , and it turns out the amd voltage settings returned to factory on both amd radeon software and msi afterburner, above that the game keeps crashing at fast scenes , its literally unplayable. Is there a fix for that ? How to keep the gpu undervolted?
newest graphic drivers installed.
 

Phaaze88

Titan
Ambassador
other games on dx12 take around 150-160w (it doesnt overheat the gpu tho)
That's a good 30-40w less, that's why it doesn't run as hot. More power = more heat; voltage is relative to that.

I'd suggest downloading Display Driver Uninstaller: https://www.wagnardsoft.com/
Run it in Safe Mode, and try installing a different driver, and see if your power profile is still being ignored.

Is Radeon Settings/Wattman included in the driver package, or is it a separate package? I may have another idea if it's the latter.
 

puw2

Reputable
Im assuming that you are using wattman which is known to reset your settings for whatever reason usually after a driver update or just from a reboot.

If you want to keep using wattman for uv and/or oc i'd recommend for you to save your settings and check that they have been applied every time you start up your pc.
 
Reactions: odongo
Jul 23, 2016
61
0
4,530
0
Im assuming that you are using wattman which is known to reset your settings for whatever reason usually after a driver update or just from a reboot.

If you want to keep using wattman for uv and/or oc i'd recommend for you to save your settings and check that they have been applied every time you start up your pc.
im adjusting the voltage on both msi afterburner and wattman , with msi afterburner being the main as i have the startup button toggled to keep my settings everytime i turn my pc, and since then it hasnt reverted , but with metro exodus and other games using dx12 it reverts them back.
using dx11 in metro doesnt do anything and what i found to be a temporary solution was to lower the shading rate to 0.7, the gpu doesnt draw as much power but the resolution is <Mod Edit>.
 
Last edited by a moderator:
Jul 23, 2016
61
0
4,530
0
Is it only Metro ignoring the undervolts?
metro exodus is fully ignoring the undervolts , it takes 190w at full load
other games on dx12 take around 150-160w (it doesnt overheat the gpu tho)
games with vsync on dx11 (rainbow six siege, gta V , smite , ace combat 7) use around 140-160w and the gpu temp keep at 67-70 degrees
 

Phaaze88

Titan
Ambassador
other games on dx12 take around 150-160w (it doesnt overheat the gpu tho)
That's a good 30-40w less, that's why it doesn't run as hot. More power = more heat; voltage is relative to that.

I'd suggest downloading Display Driver Uninstaller: https://www.wagnardsoft.com/
Run it in Safe Mode, and try installing a different driver, and see if your power profile is still being ignored.

Is Radeon Settings/Wattman included in the driver package, or is it a separate package? I may have another idea if it's the latter.
 

HoPStA

Honorable
Nov 1, 2014
42
1
10,535
0
I own a fatboy too...(I'm having other issues myself) BUT, dealt with this. If you have the AMD software installed, it cancels everything out. The AMD software is like a JEEP...Just Enough Essential Parts. HAHA!! Anyways...I started using the AMD software and my temp was staying at a solid 45-50 C from then out. I've noticed a few glitches... Go to Perfance tab...or whatever, look for temp or Fan control. Put it to manual. Then click advanced setttings, and set your markers (ya know....what speed at what temp) Click apply and you'll watch the temp drop QUICK! HOWEVER!!! Here's the trick...It does keep your settings, but sometimes the fans don't come on. If that happens, hit the "Reset" or "Default Settings" button...the button next to apply. Set the manual thing up and it'll snap back on. It works. Mine's always cool to the touch. Just a little loud, but that's what headphones are for. lol....hope that helps
 
Reactions: Phaaze88
Jul 23, 2016
61
0
4,530
0
That's a good 30-40w less, that's why it doesn't run as hot. More power = more heat; voltage is relative to that.

I'd suggest downloading Display Driver Uninstaller: https://www.wagnardsoft.com/
Run it in Safe Mode, and try installing a different driver, and see if your power profile is still being ignored.

Is Radeon Settings/Wattman included in the driver package, or is it a separate package? I may have another idea if it's the latter.
the fix was that i closed msi afterburner and reapplied the undervolts while playing , and my temps were at least normal , till the game crashes , i managed to finish the game , frames were good but the crashes were a pain, still the game was great and loved it. apart from metro all games seem to use 140-160watts and arent overheating my gpu.
 
Jul 23, 2016
61
0
4,530
0
I own a fatboy too...(I'm having other issues myself) BUT, dealt with this. If you have the AMD software installed, it cancels everything out. The AMD software is like a JEEP...Just Enough Essential Parts. HAHA!! Anyways...I started using the AMD software and my temp was staying at a solid 45-50 C from then out. I've noticed a few glitches... Go to Perfance tab...or whatever, look for temp or Fan control. Put it to manual. Then click advanced setttings, and set your markers (ya know....what speed at what temp) Click apply and you'll watch the temp drop QUICK! HOWEVER!!! Here's the trick...It does keep your settings, but sometimes the fans don't come on. If that happens, hit the "Reset" or "Default Settings" button...the button next to apply. Set the manual thing up and it'll snap back on. It works. Mine's always cool to the touch. Just a little loud, but that's what headphones are for. lol....hope that helps
thanks for the reply man , apart from metro most games dont overheat my gpu , i managed to finish metro and fix the problem but the game crashes sometimes , all it took was to apply undervolts while playing , since the game resets the settings , and my fan curve is manually made by me , now most of my games leave my gpu around 75 degrees (its very hot now), in winter it was usually at 67-69c.
 
Jul 12, 2020
4
2
15
0
So I got an RX 590 Fatboy thinking it was a good deal, meh at best. As you noticed the thing could bake cookies. I had set the air flow in my case to keep everything cold enough to keep a beer frosty to counter the fatboy. I never undervolted or any of that because I had tried it and didn't want to deal with crashes. Just yesterday I did 3 things and now I can run Borderlands 3 on Ultra with the Fatboy maxing out at 69 (previously it would spike to high 80's), it's standard temp is now mid 30's and in most games averages about 62-65ish. Here's what you do:

  1. Take the graphics card apart, the 590 tear down video shows how easy it is to do. Do make sure you have Thermal Compound so you can put the card back together.
  2. If you watched the RX 590 Fatboy Tear down video he points out the giant metal plate on the top does NOTHING. Actually he's wrong, it traps an insane amount of heat on the card, not to mention it puts an inordinate amount of weight on the pci slot. I took that off and thew it away, with prejudice.
  3. Cleaned everything off and put new Thermal compound on it, and put it back together (minus the evil metal plate). I had read a couple reviews where people had said new thermal compound by itself cut 15 degrees off the running temp
  4. Now the card has a dual bios, one for "Quiet Mode" (less fans and less noise) and one for "Performance mode" (fans run t keep the GPU cool regardless of noise). To switch between these 2 bios settings there is a tiny little switch by the power supply connection. Now per the manufacturers documentation (which was poor and hard to find for this part of the card) the "Performance mode" bios is set when the switch is pushed towards the power supply connection. I had found numerous postings where people had said that isn't correct as they pushed it away from power supply connection and there card temps dropped by leaps and bounds. So I tested this and put the switch pushed to the rear (towards the power supply connection) turned on my system played for a bit, then shut my system off and switched the switch (which you can do while the card is still in the case!) and tested it again. With the switch pushed away from power supply connection everything was about 8-10 degrees cooler
So now with system fans and gpu fans running on manufacturers default settings, no tweaking or undervolting or ritualistic voodoo sacrifices in use, I get:
  • 34 degrees for regular operating temps
  • Borderlands3 on Ultra doing a benchmark test maxed at 67
  • Pplaying B3 on Ultra with a ton of enemies on screen and me shooting lots of graphic heavy weapons maxed at 69
I hope this helps. Less than 10 minutes of messing wth th ecard will drop your in game temp by 20, and you wont have to undervolt anymore. I can post screen shots for any doubters.
 
Reactions: odongo and Phaaze88

ASK THE COMMUNITY

TRENDING THREADS