[SOLVED] Screen seems fuzzy / blurry?

Jul 11, 2021
10
3
25
1
Hi all,

just did a clean install of windows 10 with mostly new components and the screens looks a bit fuzzy or blurry. Its hard to describe, so here is a screenshot.
Take a look at the edges of the facebook, youtube, instagram and Gmail icons.



I hope it comes across, but to me it looks similar to what a heavily compressed jpeg would look like. Edges seem to be a bit blurry, colours look slightly off etc.

It is the same monitor, same cable, same graphics card, but all other components are new with a fresh install of Windows 10 .

I already tried the ClearType Tuner with ClearType turned on looking better. I don't think its that as images, or just about everything seems to be affected.

Any ideas? I am scratching my head...

Thanks!
 
Jul 11, 2021
10
3
25
1
ok, i think i found the issue.

If i change the refresh rate to anything less than 144 Hertz, everything looks fine.

Only on 144 Hz it look blurry. I don't remember if i had it on 120 Hz or 144 Hz before i did a fresh install of Windows, but it might be the cable then, or the monitor not coping with the 144 Hz given its a "budget" ultrawide...?
 

taeioum

Respectable
It's probably your monitor, the screenshot comes through sharp as can be. There should be some sort of auto adjustment function on your monitor accessed through the menu. If you can't find it, let me know what monitor you have so I can guide you through it :)
 
Jul 11, 2021
10
3
25
1
Its a Xiomi Mi 34 Ultrawide monitor. As i said, the monitor is the same, so maybe i lost some colour calibration file i may have had with the previous install of Windows...?
 
Jul 12, 2021
10
1
15
0
Hi all,

just did a clean install of windows 10 with mostly new components and the screens looks a bit fuzzy or blurry. Its hard to describe, so here is a screenshot.
Take a look at the edges of the facebook, youtube, instagram and Gmail icons.



I hope it comes across, but to me it looks similar to what a heavily compressed jpeg would look like. Edges seem to be a bit blurry, colours look slightly off etc.

It is the same monitor, same cable, same graphics card, but all other components are new with a fresh install of Windows 10 .

I already tried the ClearType Tuner with ClearType turned on looking better. I don't think its that as images, or just about everything seems to be affected.

Any ideas? I am scratching my head...

Thanks!
As you mentioned that you just did a clean re-install of Windows 10, did you also updated your system? Please note that after a clean installation, the system may miss driver updates (for graphic driver).

So, try to update your system and then restart the system, it will fix the issue
 
Jul 11, 2021
10
3
25
1
As you mentioned that you just did a clean re-install of Windows 10, did you also updated your system? Please note that after a clean installation, the system may miss driver updates (for graphic driver).

So, try to update your system and then restart the system, it will fix the issue
i did download the latest NVIDIA drivers, so i don't think its a driver issue. Maybe colour depth, my monitor is showing as 8-bit at the moment. i'll see if i can increase that...



interestingly, clicking on properties for Display 1 it says its on 32 bit

 
Last edited:
Jul 11, 2021
10
3
25
1
ok, i think i found the issue.

If i change the refresh rate to anything less than 144 Hertz, everything looks fine.

Only on 144 Hz it look blurry. I don't remember if i had it on 120 Hz or 144 Hz before i did a fresh install of Windows, but it might be the cable then, or the monitor not coping with the 144 Hz given its a "budget" ultrawide...?
 

ASK THE COMMUNITY